kann mir jemand bei ner php frage helfen ???

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von Prosac2003, 03.11.2004.

  1. Prosac2003

    Prosac2003 Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    24.10.2004
    Hi leute,

    ich habe heute versucht mein forum (wbb 1.2) auf das wbb lite zu updaten undbekomme folgenden fehler :

    SQL-DATABASE ERROR

    Database error in WoltLab Burning Board: Invalid SQL: INSERT IGNORE INTO bb2_threads (threadid,boardid,topic,starttime,starterid,starter,lastposttime,lastposterid,lastposter,replycount,views,closed,important,visible) VALUES ('586','15','Ringelhandgarnelenbecken einrichtung , worauf achten ??','1096039637','124','Ich bin's...','1096041768','63','BlackSun','1','25','0','0','1')
    mysql error: You have an error in your SQL syntax near 's...','1096041768','63','BlackSun','1','25','0','0','1')' at line 2
    mysql error number: 1064
    Date: 03.11.2004 @ 12:21
    Script: /wirbellose1/acp/update.php?step=3&page=6
    Referer:

    kann mir das mal jemand übersetzen und mir sagen was ich machen muss ?

    thx Prosac
     
  2. fons

    fons MacUser Mitglied

    Beiträge:
    239
    Zustimmungen:
    6
    MacUser seit:
    18.11.2003
    das php skript will inserts in enie mysql db machen und produziert einen syntax error. der grund ist vermutlich folgender teil:

    'Ich bin's...'

    das soll 1 durch einfache hochkommata begrenzter string sein, der aber blöderweise selbst ein hochkomma enthält :(

    versuch mal, den text im forum zu finden und auf "Ich bins ..." auszu bessern, dann das ganze nochmal laufen zu lassen ...

    lg, fons
     
  3. Prosac2003

    Prosac2003 Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    24.10.2004
    gut, das ging und nu :
    Warning: fopen(lib/options.inc.php) [function.fopen]: failed to create stream: Permission denied in /www/htdocs/v129696/wirbellose1/acp/lib/class_options.php on line 12

    Warning: fwrite(): supplied argument is not a valid stream resource in /www/htdocs/v129696/wirbellose1/acp/lib/class_options.php on line 13

    Warning: fwrite(): supplied argument is not a valid stream resource in /www/htdocs/v129696/wirbellose1/acp/lib/class_options.php on line 15

    Warning: fwrite(): supplied argument is not a valid stream resource in /www/htdocs/v129696/wirbellose1/acp/lib/class_options.php on line 15

    mfg prosac
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.042
    Zustimmungen:
    1.317
    MacUser seit:
    13.09.2004
    class_options.php versucht in die Datei options.inc.php zu schreiben, hat aber keine Rechte das zu tun. Wie heißt der user unter dessen Konto apache läuft (httpd.conf) ? Mit diesem User (wwwrun ?):
    >chown wwwrun options.inc.php
    >chmod u+w options.inc.php

    eventuell wird das für das gesamte Verzeichnis nötig werden die Rechte anzupassen.
     
  5. sevY

    sevY Gast

    Ich würde das auf chmod(0655) setzen… höchstwahrscheinlich läuft der Apache als Owner.

    Yves
     
  6. Prosac2003

    Prosac2003 Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    24.10.2004
    hab das ganze mal auf 655 gesetzt und immernoch triit der fehler auf
     
  7. sevY

    sevY Gast

    dann probier mal 0777
     
  8. Prosac2003

    Prosac2003 Thread Starter MacUser Mitglied

    Beiträge:
    142
    Zustimmungen:
    0
    MacUser seit:
    24.10.2004
    hab schon :) thx für eure hilfe
     
  9. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.042
    Zustimmungen:
    1.317
    MacUser seit:
    13.09.2004
    Autsch! Das ist aber Teufel mit Belzebub austreiben! Klar hilft es die Rechteverwaltung quasi zu inaktivieren. In einem öffentlichen Netz wäre das aber tödlich. Ein

    grep User /etc/httpd.conf
    cd /to/the/path/
    chown -R USER *

    wäre da sicherer gewesen!
     
  10. sevY

    sevY Gast

    Ich hatte auch schon ein schlechtes Gewissen deswegen… ;)
    Rechte sollte man natürlich so restriktiv wie möglich setzen.


    Yves
     
Die Seite wird geladen...