Kann keinen neuen Drucker hinzufügen

Diskutiere mit über: Kann keinen neuen Drucker hinzufügen im Utilities und Treiber Forum

  1. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Hallo,

    das ist mein erster Eintrag in diesem Forum. :)

    Ich habe folgendes Problem auf meinem PB 12" unter Mac OS X 1.4.6: wenn ich einen neuen Drucker in Printer Setup Utility hinzufügen möchte, passiert nichts. Ich klicke auf "Add+" und es passiert nichts. Keine Fehlermeldung, kein Fenster. Mittlerweile habe ich alle Drückereinstellungen Zurückgesetzt und jetzt habe ich keinen Drucker mehr und kann auch keinen neuen hinzufügen.

    Im Internet bin ich auf das Programm Printer Setup Repair gestoßen und alles mögliche ausgeführt, es hat aber nicht geholfen. Darunter findet Ihr die Log-Datei dieses Programmes.

    ===================================================================
    Freitag, 23. Juni 2006 15:17:07 Uhr
    Launched Printer Setup Repair 5.0.5
    --------------------------------------------
    Registered to: *UNREGISTERED COPY*
    --------------------------------------------
    User name: joanna
    User ID No: 501
    OS X vers: 10.4.6
    ------------------------
    15:18:38 Uhr
    Begin deleting temporary files for all users...
    Unable to complete the process. Error type 1: Unable to delete temporary files because the /private/tmp/501/TemporaryItems directory is missing or empty.
    ------------------------
    15:18:51 Uhr
    Begin deleting preference files for all users...
    Deleting the com.apple.print.PrintCenter.plist file for all users...
    The com.apple.print.PrintCenter.plist file was deleted successfully for all users.
    Deleting the com.apple.print.PrintingPrefs.plist file for all users...
    Unable to delete the com.apple.print.PrintingPrefs.plist file for all users because none could be found.
    Deleting the com.apple.print.custompresets.plist file for all users...
    Unable to delete the com.apple.print.custompresets.plist file for all users because none could be found.
    Deleting the com.apple.print.custompapers.plist file for all users...
    Unable to delete the com.apple.print.custompapers.plist file for all users because none could be found.
    Deleting the com.apple.print.Cache.plist file for all users...
    Unable to delete the com.apple.print.Cache.plist file for all users because none could be found.
    Deleting the com.apple.print.favorites.plist file for all users...
    Unable to delete the com.apple.print.favorites.plist file for all users because none could be found.
    Deleting the com.apple.print.PrinterProxy.plist file for all users...
    Unable to delete the com.apple.print.PrinterProxy.plist file for all users because none could be found.
    1 preference file was deleted successfully.
    6 preference files could not be deleted because they could not be found.
    ------------------------
    15:19:07 Uhr
    Verifying /private/tmp directory and /tmp symbolic link permissions...
    Verification complete.
    No problems found with the /private/tmp directory and /tmp symbolic link permissions.
    ------------------------
    15:19:36 Uhr
    Verifying root user...
    The information for the root user appears to be valid.
    ------------------------
    15:19:42 Uhr
    Verifying Printing Services user...
    The information for the Printing Services user appears to be valid.
    ------------------------
    15:19:49 Uhr
    Verifying Print Operators group...
    The information for the Print Operators group appears to be valid.
    ------------------------
    15:20:00 Uhr
    Begin permission verification and repair...
    The owner setting for the directory /private/etc/cups is incorrect!
    It is 501, but should be 0
    Repairing the directory /private/etc/cups owner setting ... done.
    The owner setting for the directory /private/etc/cups/certs is incorrect!
    It is 501, but should be 0
    Repairing the directory /private/etc/cups/certs owner setting ... done.
    The file /private/etc/cups/classes.conf is missing. This file is deleted when using the Reset Printing System option.
    The owner setting for the file /private/etc/cups/cupsd.conf is incorrect!
    It is 501, but should be 0
    Repairing the file /private/etc/cups/cupsd.conf owner setting ... done.
    The owner setting for the file /private/etc/cups/cupsd.conf.bak is incorrect!
    It is 501, but should be 0
    Repairing the file /private/etc/cups/cupsd.conf.bak owner setting ... done.
    The owner setting for the directory /private/etc/cups/ppd is incorrect!
    It is 501, but should be 0
    Repairing the directory /private/etc/cups/ppd owner setting ... done.
    The file /private/etc/cups/ppds.dat is missing. This file is deleted when using the Reset Printing System option.
    The file /private/etc/cups/printers.conf is missing. This file is deleted when using the Reset Printing System option.
    The owner setting for the directory /private/var/spool/cups is incorrect!
    It is 501, but should be 0
    Repairing the directory /private/var/spool/cups owner setting ... done.
    The owner setting for the directory /private/var/spool/cups/tmp is incorrect!
    It is 501, but should be 0
    Repairing the directory /private/var/spool/cups/tmp owner setting ... done.
    The owner setting for the file /private/var/log/cups/access_log is incorrect!
    It is 501, but should be 0
    Repairing the file /private/var/log/cups/access_log owner setting ... done.
    The permissions for the file /Users/joanna/Library/Preferences/Acrobat Distiller Prefs are incorrect!
    They are -rw-rw-rw-, but should be -rw-rw-r--
    Repairing the file /Users/joanna/Library/Preferences/Acrobat Distiller Prefs permissions ... done.
    Recreating symbolic links...
    Deleting the /usr/libexec/cups/backend/fax symbolic link...
    Recreating the /usr/libexec/cups/backend/fax symbolic link...
    Deleting the /usr/libexec/cups/backend/smb symbolic link...
    Recreating the /usr/libexec/cups/backend/smb symbolic link...
    Deleting the /usr/libexec/cups/backend/http symbolic link...
    Recreating the /usr/libexec/cups/backend/http symbolic link...
    Deleting the /usr/libexec/cups/filter/pdftopm symbolic link...
    Recreating the /usr/libexec/cups/filter/pdftopm symbolic link...
    Symbolic links recreated.
    Verification complete.
    2085 files examined. 9 problems were found and repaired.
    Missing files/directories were found.
    ------------------------
    15:34:48 Uhr
    Deleting the contents of the /private/var/spool/cups directory...
    No spool files were located in the /private/var/spool/cups directory.
    ------------------------
    Freitag, 23. Juni 2006 15:41:55 Uhr
    Printer Setup Repair 5.0.5 exited normally.


    Seid Ihr in der Lage mir zu sagen, was ich vielleicht noch machen kann um Druckersystem zu reparieren? Ich würde sehr ungerne das gesamte System neu installieren, weil ich *sehr* viele Einstellungen vorgenommen habe, die sich nicht so einfach wiederherstellen lassen.

    Wenn noch irgendwelche Daten fehlen, die zum feststellen der Ursache meines Problemes nötig sind, sagt bitte Bescheid.


    Grüße,

    Joanna
     
  2. rpoussin

    rpoussin MacUser Mitglied

    Beiträge:
    17.789
    Zustimmungen:
    1.147
    Registriert seit:
    22.08.2004
    Hallo,
    wie lange wartest Du, wenn Du auf HINZUFÜGEN gedrückt hast. Der Mac sucht an allen aktiven Netzwerkverbindungen, ob er einen Drucker findet. Deaktiviere Netzwerkverbindungen, die Du nicht brauchst.
     
  3. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Lange.

    Ich bin jetzt offline gegangen. Keine Netzwerkverbindungen waren aktiv. Und es passiert trotzdem nichts. (Übrigens ich muss u.a. zwei Drucker über TCP/IP in einem großen Netz hinzufügen aber auch einen lokalen Drucker.)

    Noch eine Idee?
     
  4. mikne64

    mikne64 MacUser Mitglied

    Beiträge:
    3.097
    Zustimmungen:
    92
    Registriert seit:
    02.04.2004
    Hi,

    willkommen im Forum! :)

    Du könntest mit dem Festplattendienstprogramm am Volume die Rechte reparieren.

    Wenn Du den Drucker hinzufügst, aber nicht automatisch, sondern manuell über die IP-Adresse, funktioniert das?

    Viele Grüße
     
  5. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Das hat auch nichts gebracht.

    Was meinst du damit? Ich kriege sogar kein Fenster zum Hinzufügen eines Druckers. Daran liegt das Problem. Ich kann weder einen Drucker auswählen noch einen manuell hinzufügen, weil es keine Möglichkeit dafür gibt.

    Noch mal:

    Ich öffne System Preferences.
    Klicke auf „Print & Fax“.
    Ich klicke auf „+“ unter der leeren Liste von Drucker.
    Es wird Printer Setup Utility geöffnet. (vorhin habe ich „Reset printing system…” gewählt, so jetzt ist alles wie frisch installiert)
    „You have no printers available. Would you like to add to your list of printers now?“ (OF COURSE!) --> Ich klicke auf „Add“.
    Passiert nichts. Ich bin in einem Fenster mit der leeren Liste von Drucker in Printer Setup Utility. Das Klicken auf „Add+“ bringt nichts.

    So sieht es aus. Etwas ist kaputt und ich kann nicht feststellen, was.

    Ich habe schon versucht, aus einem anderen Benutzerkonto, das auch über Adminrechte verfügt, einen Drucker hinzuzufügen, es verhält sich aber genauso.

    Vielleicht gibt es eine Möglichkeit, vorläufig die Drucker aus dem Kommandozeile zu installieren oder über einen Webinterface? (Ich habe vorhin Linux benutzt und das waren die einzigen Möglichkeiten) Damit ich nicht das gesamte System neu installieren müßte um die Druckerverwaltung zu reparieren.


    Grüße,

    Joanna
     
  6. OFJ

    OFJ MacUser Mitglied

    Beiträge:
    9.075
    Zustimmungen:
    537
    Registriert seit:
    15.10.2004
    Hast Du die entsprechenden Druckertreiber auf Deinem System?
     
  7. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Ich würde höchstwahrscheinlich sagen: ja. Bewusst habe ich sie nicht entfernt. Auch das Printer Setup Repair Programm weißt darauf hin, welche Treiber man evtl. entfernen könnte.

    In /Library/Printers gibt es eine Menge Dateien. Sie sollen also da sein.
     
  8. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Noch als Ergänzung: ich habe es versucht einen Drucker über cups (localhost:631) hinzuzufügen. Es scheiterte aber, weil ich keinen Treiber für meinen Drucker (EPSON Stylus Photo D68) in Cups gefunden habe. :( Ich weiß also nicht, ob das irgendwie helfen könnte.

    Das sieht alles irgendwie merkwürdig aus. Kein Aufräumen hilft. Kein Reset von Einstellungen. Gar nichts.
     
  9. joannaludmila

    joannaludmila Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    23.06.2006
    Es gibt Neuigkeiten, obwohl noch keine vernünftige Lösung. Vielleicht wird es Euch etwas sagen.

    Und zwar gab es in error_log von cups folgende Fehlermeldungen:

    I [26/Jun/2006:00:33:23 +0200] Full reload is required.
    E [26/Jun/2006:00:33:23 +0200] LoadAllPrinters: Unable to open /private/etc/cups/printers.conf - No such file or directory
    E [26/Jun/2006:00:33:23 +0200] LoadAllClasses: Unable to open /private/etc/cups/classes.conf - No such file or directory
    I [26/Jun/2006:00:33:23 +0200] Full reload complete. ​

    Die beiden Dateien sind aber da, nur aber mit Zugrifsrechten 600, die habe ich auf 644 geändert (sinnvoll?).

    Dann probierte ich den Drucker neu zu addieren und habe zufällig in dem console.log folgende Einträge entdeckt:

    2006-06-26 17:09:38.254 Printer Setup Utility[282] *** -[FireWireBrowser startBrowsing]: selector not recognized [self = 0x50fe120]
    2006-06-26 17:09:38.255 Printer Setup Utility[282] *** -[FireWireBrowser startBrowsing]: selector not recognized [self = 0x50fe120]
    2006-06-26 17:09:42.120 Printer Setup Utility[282] *** -[FireWireBrowser startBrowsing]: selector not recognized [self = 0x5676e90]
    2006-06-26 17:09:42.121 Printer Setup Utility[282] *** -[FireWireBrowser startBrowsing]: selector not recognized [self = 0x5676e90] ​

    Das Suchen in Google ergab nur ein Ergebnis: http://tnij.org/fhx. Leider hat dort die Person, die das Thema angefangen hat, nicht geantwortet, ich weiß also nciht, ob er irgendwie erfolgreich war. Leider kann ich die Antwort auch nicht nachvollziehen, außer der Benutzung von diesem Programm zum Reparieren.

    Vielleicht kennt sich jemand von Euch aus? Was nun?
     
  10. Freibeuter

    Freibeuter MacUser Mitglied

    Beiträge:
    50
    Zustimmungen:
    2
    Registriert seit:
    19.03.2006
    Genau dieses Problem habe ich auch mit meinem MBP und OS X 10.4.8. Habe jetzt den ganzen Abend recherchiert und ausprobiert - ohne Erfolg. Ich wollte mein System eigentlich erst neu aufsetzen, wenn Leopard kommt, aber jetzt werde ich es wohl schon vorher machen müssen.

    So ganz ohne Drucker geht es dann doch nicht. Oder hat jemand noch eine Idee?
     
Die Seite wird geladen...
Ähnliche Themen - Kann keinen neuen Forum Datum
App mit der man Einzeldatein in Einzelordner legen kann in einem Rutsch Utilities und Treiber 27.12.2015
Alternative zu memtest, die mehr als 2GB testen kann??? Utilities und Treiber 09.04.2015
Teamviewer kann nicht installiert werden Utilities und Treiber 27.01.2014
Die Festplatte enthält das Startvolumen und kann nicht partitioniert werden! Utilities und Treiber 22.11.2011
Wie hieß das App, mit dem man Fenster auf halben Bildschirm vergrößern kann? Utilities und Treiber 27.07.2011

Diese Seite empfehlen