Java-Cocoa-Applikationen auf IntelMacs

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von Jan-Michael, 12.01.2006.

  1. Jan-Michael

    Jan-Michael Thread Starter MacUser Mitglied

    Beiträge:
    391
    Zustimmungen:
    0
    MacUser seit:
    28.02.2005
    Hallo Leute,

    erstmal eine relativ generelle Frage zu den neuen IntelMacs. Werden Cocoa-Java-Programme auch ohne neues Kompilieren auf den IntelMacs laufen, wenn sie auf einem PPC compiliert wurden?
     
  2. Gremlin

    Gremlin MacUser Mitglied

    Beiträge:
    743
    Zustimmungen:
    3
    MacUser seit:
    11.01.2006
    Solange sie keine weiteren nativen (JNI) Bibliotheken einsetzen, ja. JNI-Bibliotheken müssen als Universal Binaries kompiliert sein, damit sei auf einem Intel-Mac verwendbar sind. Ein Java-Programm das PowerPC JNI-Bibliotheken einsetzt, läuft nicht auf Intel-Macs - auch nicht unter Rosetta.

    Gremlin
     
  3. Jan-Michael

    Jan-Michael Thread Starter MacUser Mitglied

    Beiträge:
    391
    Zustimmungen:
    0
    MacUser seit:
    28.02.2005
    Danke für deine schnelle Antwort :D.
     
  4. xero

    xero MacUser Mitglied

    Beiträge:
    679
    Zustimmungen:
    1
    MacUser seit:
    29.05.2005
    Werden die Intel Macs eigentlich mit Java 1.5 bzw. 5.0 ausgeliefert?
     
  5. Jan-Michael

    Jan-Michael Thread Starter MacUser Mitglied

    Beiträge:
    391
    Zustimmungen:
    0
    MacUser seit:
    28.02.2005
    @xero: k.a., denke aber schon. Schließlich läuft auf denen doch OS X 10.4.4 . Da ist Java 5.0 doch mit drin, oder?
     
  6. Gremlin

    Gremlin MacUser Mitglied

    Beiträge:
    743
    Zustimmungen:
    3
    MacUser seit:
    11.01.2006
    Nein, Standard ist immer noch 1.4.2 - ziemlich peinlich, dass Apple dabei immer noch ihre ach so tolle Java-Unterstützung anpreist. Java 1.5 muss man separat downloaden und installieren. Das nächste Update von Java 1.5 wird sich als Standard-JVM installieren, aber die gibt es bis jetzt nur als Developer Preview nur für PPCs.
    Von daher glaube ich nicht, dass die Intel-Macs standardmässig mit Java 1.5 kommen. Ich habe aber (noch) keinen hier stehen, deswegen kann ich es nicht sicher sagen.

    Gremlin
     
Die Seite wird geladen...