iTuens.....Lieder gehen kaputt

Dieses Thema im Forum "Mac OS X Apps" wurde erstellt von olymp, 15.01.2005.

  1. olymp

    olymp Thread Starter MacUser Mitglied

    Beiträge:
    591
    Zustimmungen:
    4
    MacUser seit:
    15.04.2004
    Hallo Freunde,- User und Freaks,

    wir haben ein (für uns) großes Problem.

    Seit über einem Jahr sind wir sehr glücklich mit dem neuen Powerbook
    und arbeiten viel mit itunes. (4.7)
    Bei ca. 4000 Songs lief das alles bestens.
    Habe auch ständig für nötige Updates gesorgt etc.

    Seit einigen Tagen jedoch, sind einige und es werden ständig mehr...Songs nicht mehr abspielbar....was sich wie folgt darstellt.

    Wenn ich z.b eine Wiedergabeliste auswähle, aus der ich einen oder mehrere songs laufen lassen möchte, in welcher sich ein anscheindender CORPUS DELIKTUS befindet dann fängt das Ding erst garnicht an zu spielen, bzw.
    springt nach 2-3 sek. Spielzeit auf das nächste File und bleibt schliesslich stehen. Bringt aber auch überhaupt keine Meldung oder ähnliches.

    Ab und zu erscheint im rechten Teil der playlists an stelle des Häckchens ein ausrufungszeichen, welches aber wieder verschwindet, wenn ich in den Einstellungen "Orderverwaltung, aktiviere, bzw. deaktiviere....

    Wie gesagt scheint hier ein Song nach dem anderen abzukacken.........

    Habe zwar ein Backup, welches inzwischen nicht mehr ganz aktuell ist, aber trotzdem. wenn ich das Zeug rüberkopiere, fängts irgendwann wieder an.
    Darüberhinaus sorge ich auch für eine regelmässige Systempflege und checke das also auch ständig...

    Hat jemand eine Idee??

    merci im Vorraus
     
  2. ststephen

    ststephen MacUser Mitglied

    Beiträge:
    93
    Zustimmungen:
    0
    MacUser seit:
    15.12.2003
    Hast Du den Ordner mit den Music-Files in den letzten Tagen verschoben?
    Schau mal in den Einstellungen/Erweitert, wo iTunes die Datein suchen soll, und
    dann schau mal, wo sie tatsächlich liegen!
     
  3. René

    René MacUser Mitglied

    Beiträge:
    467
    Zustimmungen:
    0
    MacUser seit:
    29.04.2002
    Ich hatte das Problem anfänglich auch. ..grübel.... es waren glaube ich gleichnamige Titel oder Ordner, wo ich noch nicht "automatische Verwaltung" genutzt hatte, weil ich diese Ordnung nicht so gelungen fand. Suche mal solche raus. Wenn dem so ist, muss der Titel minimal geändert werden.
     
  4. Macbeatnik

    Macbeatnik MacUser Mitglied

    Beiträge:
    351
    Zustimmungen:
    0
    MacUser seit:
    12.04.2004
    Das Ausrufezeichen ist ein Zeichen dafür wie auch oben schon erwähnt,das die Dateien nicht gefunden werden,war bei mir auch mal der Fall als ich die Ordner neu angelegt hatte und umgruppiert habe.Ich habe mir dann die Mühe gemacht die Biblithek zu löschen (!!!!nur die Verweise nicht die Dateien!!!! wichtig!!) und sie dann neu angelegt, gibt aber bestimmt auch besser Methoden.
     
  5. smart

    smart MacUser Mitglied

    Beiträge:
    194
    Zustimmungen:
    1
    MacUser seit:
    14.04.2003
    Das Ausrufezeichen bedeutet (wie schon beschrieben), das der Verweis in der iTunes Bibliothek nicht mehr mit dem Pfad zur Datei übereinstimmt. Ich hatte dieses Problem ebenfalls nachdem ich sämtlich Dateien auf eine externe Festplatte ausgelagert hatte. Seltsam war, dass nur einige Dateien nicht gefunden wurden. (Tip: mal alle Titel in der Bibliothek markieren, mit dem Mauszeiger packen und etwas verschieben. Dann werden vor alle Titel, die nicht gefunden werden, Ausrufezeichen gesetzt.) Nach langer Suche in der Bibliotheksdatei (XML version), habe ich festgestellt, das nicht das Verschieben das Problem war.

    Ich hatte in der Vergangenheit deutsche und englische Versionen von iTunes installiert (WinXP). Das hat alles durcheinander gebracht. 'Compilations' in der englischen Version, sind 'Sammlungen' in der deutschen. Weitere Probleme gab es dann auch durch 'Unbekanntes Album' und 'Unknown Album', 'Unknown Artist' und 'Unbekannter Interpret' etc. - irgendwie hat sich iTunes bei der Organisation da verschluckt ... (oder ich war zu unwissend)

    Die Bibliothek befindet sich in der Datei 'iTunes 4 Music Library.itl'. Beim Beenden oder Start von iTunes wird eine XML Export dieser Datei angelegt. Ein Edit dieser XML Datei bringt leider gar nichts, da sie eben immer neu angelegt wird. Das proprietäre Format der ITL Datei lässt sich nicht editieren. Damit hatte sich die Hoffnung zerschlagen, das Problem einfach durch editieren der XML Datei zu lösen.

    Mein Lösung war:
    - Pfad zu einem Titel in der XML Datei suchen
    - Pfad auf der Festplatte anpassen.

    Um dem Problem in Zukunft zu entgehen, habe ich keinen Titel mehr ohne Album und Interpretenname.

    Wenn du die ITL Datei löschst, verlierst du einen Teil der Informationen: Playlists, Zähler für jeden Titel, ImportDatum etc.. Alle Daten die in der AAC-MP3- .. Datei gespeichert werden gehen natürlich nicht veloren.

    s.
     
  6. olymp

    olymp Thread Starter MacUser Mitglied

    Beiträge:
    591
    Zustimmungen:
    4
    MacUser seit:
    15.04.2004
    Zunächst einmal danke an alle,
    die sich meinen Problem angenommen haben....

    wie gesagt, hat sich das Problem mit den"Ausrufungszeichen"..bzw. angeblich fehlenden Files erledigt, als ich die Ordnerverwaltung zu erst deaktiviert und danach wieder aktiviert habe.........

    Die Ausrufungzeichen erscheinen nicht mehr........

    dennoch wie gesagt. Einzelne Songs bzw ganze Wiedergabelisten lassen
    sich nicht mehr apspielen und/oder springen nach 2-3 Sek. Spielzeit eines Fiels automatisch auf das nächste....schön der Reihe nach.
    Andere Songs wiederum bleiben einfach in der Hälfte stehen obwohl der Song eigentlich weitergehen sollte.
    Die Files selbt liegen da, wo sie immer gelegen haben.
    Wir haben weder was verschoben, noch verändert....
    lediglich ergänzt und halt iTunes upgedatet.....

    Aber vielleicht ist es doch erwähnenswert, dass wir vor einiger Zeit
    Die Festplatte ausgetauscht haben und im vorfeld das Volume "Wiederhergestellt" haben auf einer LaCie und zu guter letzt einfach wiederhergestellt haben......

    könnten da einige Files einen knall bekommen haben??
    denn wenn ich mir das richtig überlege, sind auch im iphoto bei einigen Bildern die Preview Icons seit dem weg......

    trotzdem aber tauchen diese probleme auch bei songs auf, die z.B gestern noch einwandfrei liefen und heute nicht mehr???

    wen dem so sei?????........die Songs lassen sich wohl nicht "flicken" sondern müssten erneut in die Bibliothek importiert werden???


    merci
     
  7. olymp

    olymp Thread Starter MacUser Mitglied

    Beiträge:
    591
    Zustimmungen:
    4
    MacUser seit:
    15.04.2004
    hat keiner mehr bock oder eine Idee??

    zum aufgeführten Thema bin ich über ein paar weitere antworten sehr froh


    merci
     
  8. Alexander#dje73

    Alexander#dje73 MacUser Mitglied

    Beiträge:
    503
    Zustimmungen:
    23
    MacUser seit:
    23.01.2004
    Ich würde die fehlerhaften Titel mal in z.B. "HexEdit" öffnen.
    Bestehen sie nur noch aus Nullen, sind die Daten wohl futsch..., was vielleicht beim hin- und her-kopieren über eine defekte HD passiert sein kann.

    Sonst wäre interessant, ob es sich bei den nicht spielbaren Titeln um mp3, AAC, ... handelt. Ich hatte letztlich vereinzelt Probleme mit AAC Titeln und vermute da ein Problem mit den digitalen Rechten. (einfach "Information" in iTunes auswählen)

    Wenn die Songs nur springen, aber sonst laufen, öffne sie mal in einem Audio-Editor (als freeware fällt mir da jetzt nur "Audacity" ein) und speicher sie an einen anderen Ort neu. Dadurch könnten kleinere Fehler in der Datei beseitigt werden.
     
  9. mann-aus-wurst

    mann-aus-wurst MacUser Mitglied

    Beiträge:
    2.183
    Zustimmungen:
    252
    MacUser seit:
    13.12.2004
    Culpa 10.4.2

    Hi, habe genau das selbe Problem gehabt und bin teilweise zurück zu Windows geswitcht, denn eine Installation auf 10.3.9 (wo alles, wirklich ALLES besser war) war scheinbar mit meinem iBook nicht möglich.
    Das Problem lies sich nicht beheben, die gesammte MusikBib war somit bröckelig und ungenießbar. Aufgefallen ist mir das Problem nach dem Update auf 10.4.2. AAC Dateien scheinen mir außerdem anfälliger als MP3.
    Die "Hilfe" des Forums war (zumindest in meinem Thread) teilweise :mad: .
     
  10. Elbe

    Elbe MacUser Mitglied

    Beiträge:
    1.205
    Zustimmungen:
    15
    MacUser seit:
    03.02.2005
    Was sollen denn "anfällige Dateien" sein?
     
Die Seite wird geladen...

Diese Seite empfehlen