iPhoto: "Bild drehen-Vorschau" Bug

Diskutiere mit über: iPhoto: "Bild drehen-Vorschau" Bug im Mac OS X Apps Forum

  1. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    Hallo Macuser

    Seit Neustem habe ich folgendes Problem in iPhoto 5.0.2 unter Tiger 10.4.1:

    Ich importiere neue Bilder (Auflösung und Bildgröße sind völlig egal) Wenn ich diese Bilder dann um 90 Grad nach Links drehe wird mir sofort die Vorschau aktualisert und das Bild ist auch gleich wieder zu betrachten. Aber sobald ich 180 bzw. 270 Grad nach links oder 90 Grad nach rechts drehe wird das Thumbnail weiß und das Bild kann ich nicht anschauen. Nun dauert es sehr lange (mit unter zwei Minuten) bis das Thumbnail plötzlich erscheint. Jetzt kann ich auch das Bild wieder betrachten. In der Zwischenzeit rechnet sich iPhoto aber fast zu Tode.
    Bisher hatte ich das Problem nicht und frage mich, warum iPhoto bei 5000 Photos in der Libary auf eine Sigle 1,8 Ghz G5 (das alte Modell) mit 2,5 GB RAM beim Drehen so langsam ist?

    P.S.
    - Bei einer frischen Libary mit 200 Bildern das selbe Problem.
    - Datenbank und Vorschauen usw. alles frisch aktualisiert bringt keine Verbesserung.
     
  2. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    auch eine neuinstallation von iphoto brachte keine Besserung. hat neimand diese Problem?
     
  3. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    Update auf iPhoto 5.0.4 bringt die Lösung
     
  4. GeraldH

    GeraldH MacUser Mitglied

    Beiträge:
    41
    Zustimmungen:
    1
    Registriert seit:
    21.03.2005
    Habe das gleiche Problem nun plötzlich auch unter 5.0.4. Kennt jemand inzwischen eine Lösung?
     
  5. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    hast du gleichnamige Photos in der Library? Library schon neu angelegt?
     
  6. GeraldH

    GeraldH MacUser Mitglied

    Beiträge:
    41
    Zustimmungen:
    1
    Registriert seit:
    21.03.2005
    Ja, habe gleichnamige... ziemlich viele sogar!

    Wie lege ich denn die Library neu an (sorry, bin noch relativ frischer Switcher)? Allerdings schreibst Du ja in Deinem ursprünglichen Beitrag, dass das bei Dir (zumindest unter 5.0.2) nix gebracht hat... oder hab ich Dich da faksch verstanden?
     
    Zuletzt bearbeitet: 10.09.2005
  7. quack

    quack MacUser Mitglied

    Beiträge:
    6.346
    Zustimmungen:
    141
    Registriert seit:
    29.12.2004
    Beim starten von iPhoto Apfel-alt gedrückt halten. Dann wirst du gefragt, was alles neu angelegt werden soll.
    Mach aber erst eine Kopie des iPhotoLibrary-Ordners zur sicherheit.

    Du kannst deine Kopie in iPhoto verwenden, wenn du beim starten "nur" die alt-Taste gedrückt hälst. iPhoto fragt dann, wo die zu verwendende Library ist.
     
  8. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    ich habe die Erfahrung gemacht wenn man in iPhoto gleichnamige Photos (aber vom Inhalt unterschiedlich) hat es zu genau solchen Problemen kommt. Aus diesem Grund benutze ich folgendes Programm um meine Bilder via Exif-Datum eindeutig zu benennen. Seitem läuft iPhoto defintiv besser.

    http://www.macupdate.com/info.php/id/10043
     
  9. GeraldH

    GeraldH MacUser Mitglied

    Beiträge:
    41
    Zustimmungen:
    1
    Registriert seit:
    21.03.2005
    Problem großteils gelöst: der Haken war die Quartz2DExtremeEnabled YES Einstellung in der com.apple.windowserver.plist

    Das habe ich jetzt wieder auf NO gestellt und jetzt werden die Bilder wieder sofort gedreht. Überhaupt kommt mir vor, dass jetzt alles weicher scrollt, nicht nur in iPhoto, sondern z.B. auch in Safari. Und das System läuft irgendwie generell schneller, kommt mir vor.

    Komisch ist immer noch Folgendes: wenn ich in iPhoto ein Bild drehe und es danach in GraphicConverter öffne, bekomme ich eine (abschaltbare) Fehlermeldung, dass im EXIF-Header ein Fehler ist, weil die Orientierung doppelt eingetragen ist und... tatsächlich! (siehe Bild). Scheint also wohl echt ein Bug zu sein und zwar von iPhoto - oder von Quicktime 7.0.2? (steht als Encoder im EXIF (siehe ebenfalls Bild)).

    Sehr geheimnisvoll. Fühle mich fast in alte Windowszeiten zurückversetzt.

    Aber, Fazit: Quartz2DExtreme abschalten kann gut sein...

    Gerald.

    Ach ja: OS X 10.4.2
    iPhoto 5.0.4
    1,67er PB 17"
     

    Anhänge:

  10. wetwater

    wetwater Thread Starter MacUser Mitglied

    Beiträge:
    921
    Zustimmungen:
    116
    Registriert seit:
    19.11.2003
    zuerst hat es etwas gebracht, jetzt aber tritt der alte fehler (ewige zeiten bis das rotierte Bild dargestellt wird) wieder auf. ich sag nur komisch.
     
Die Seite wird geladen...
Ähnliche Themen - iPhoto Bild drehen Forum Datum
iPhoto: Neues Bild in Thumbnail zu sehen, in normaler Darstellung schwarz oder weiß Mac OS X Apps 30.12.2013
iPhoto: vom Lesezeichen-Bild zum Originalbild Mac OS X Apps 26.02.2012
iPhoto macht kein großers Bild Mac OS X Apps 30.08.2011
iPhoto: Freigestelltes Bild Drucken Mac OS X Apps 10.01.2009
iPhoto Bild Namen geben Mac OS X Apps 13.02.2008

Diese Seite empfehlen

Benutzerdefinierte Suche