iCal via WebDAV veröffentlichen.

Dieses Thema im Forum "Mac OS X" wurde erstellt von Shakai, 03.12.2002.

  1. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    Hallo...

    Also folgendes Problem:

    Ich wollte meinen iCal via WebDAV im Internet präsentieren und habe sämtliche Veränderungen in der httpd.conf vorgenommen bis ich meinte es wäre getan. Als ich mein WebSharing wieder starten wollte kam folgende Meldung:

    Syntax error on line 388 of /etc/httpd/httpd.conf:
    DAVLockDB not allowed here
    /usr/sbin/apachectl start: httpd could not be started

    ...Jetzt frage ich mich warum "DAVLockDB not allowed here"
    Hat das was mit Rechten zu tun? Wenn ja, wo und wie muss ich die ändern.
    Wer mehr Info braucht, einfach Bescheid sagen...

    Bis dann
    Shakai
     
  2. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hi

    Das hat nichts mit Rechten zu tun, ich vermute, das du dem Server an der falschen Stelle (wahrscheinlich innerhalb einer Directory Direktive) den Pfad zu den DAVLocks beibringen willst, und das geht nicht.

    Ich habe die Konfiguration in den vHosts

    Beispiel

    <VirtualHost 10.15.x.x:80>
    ServerName xxx.de
    #WebPerfCacheEnable Off
    #SiteAutomaticallyDisabled Off
    ServerAdmin xx@xxx.de
    DocumentRoot "/Library/WebServer/Documents"
    DirectoryIndex index.html
    CustomLog "/private/var/log/httpd/access_log" "%h %l %u %t \"%r\" %>s %b"
    ErrorLog "/private/var/log/httpd/error_log"
    <IfModule mod_ssl.c>
    SSLEngine Off
    SSLLog "/private/var/log/httpd/ssl_engine_log"
    #SSLCertificateChainFile "/private/etc/httpd/ssl.crt/ca.crt101"
    #SSLCertificateFile "/private/etc/httpd/ssl.crt/server.crt101"
    SSLCertificateKeyFile "/private/etc/httpd/ssl.key/server.key101"
    SSLCipherSuite "RSA:-HIGH:-MEDIUM:-LOW:+EXP"
    #SSLPassPhrase xxx.de:80 ""
    </IfModule>
    <IfModule mod_dav.c>
    DAVLockDB "/private/var/run/davlocks/.davlock101"
    DAVMinTimeout 600
    </IfModule>
    <Directory "/Library/WebServer/Documents">
    Options All +MultiViews +ExecCGI -Indexes
    AllowOverride All
    <IfModule mod_dav.c>
    DAV On
    </IfModule>
    </Directory>
    #<Realm 1>
    <Directory "/Library/WebServer/Documents">
    AuthName "xxx.de"
    AuthType Basic
    <Limit PUT DELETE PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
    Require no-user
    </Limit>
    </Directory>
    #</Realm>
    </VirtualHost>


    Diese Konfiguation (OSX Server 10.1) konfiguriert WEBDav für die Document root ohne Password. Spezifischer Passwordschutz wird dann über die .htaccess in einem Subdirectory der document-root eingeschaltet.


    HTH

    W
     
  3. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    Hmm...bei mir sieht das ganze so aus:

    # WebDAV wird aktiviert
    DAVLockDB /Library/WebServer/davlocks/DAVLockDB
    DAVMinTimeout 600
    <Location /ical>
    DAV On
    AllowOverride None
    Options None
    AuthType Basic
    AuthName "webdav access"
    AuthUserFile "/etc/httpd/passwords/webdav.access"
    <LimitExcept GET HEAD OPTIONS>
    require user hier_stehen_die_Benutzer
    </LimitExcept>
    require valid-user
    </Location>

    Das Problem liegt in dieser Zeile:
    DAVLockDB /Library/WebServer/davlocks/DAVLockDB

    Ich habe gelesen dass das WebDAV Verzeichniss aus Sicherheitsgründen ausserhalb des Documents folder liegen sollte, stimm das?


    [Edit]Mir ist gerade ncoh etwas aufgefallen, melde mich gleich nochmal[/Edit]
     
  4. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    &nbsp;

    Ich glaube daran liegt's, mal gucken ob ich das hinbekomme.
    Danke für die Antwort...
    Shakai
     
  5. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hmmm...

    Der einzige Unterschied ist

    <IfModule mod_dav.c>
    DAVLockDB "/private/var/run/davlocks/.davlock101"
    DAVMinTimeout 600
    </IfModule>

    Das sollte jedoch nicht entscheidend sein.


    Die DAVLock solllte schon außerhalb der document-root liegen, soweit richtig. Hast die die auch erzeugt und die richtigen Rechte gesetzt

    cd /Library/WebServer/davlocks/
    touch DAVLockDB
    sudo chown www:www DAVLockDB
    sudo chmod 775 DAVLockDB

    Kennt Du diesen Thread?
    http://www.macuser.de/forum/showthread.php?s=&threadid=2944&highlight=WebDAV

    HTH

    W
     
  6. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    &nbsp;

    Jip, hatte ich alles gemacht.
    Habe es auch nochmal wiederholt, aber ich bekomme immernoch diese error Message.
    Thx für die Hilfe.
    Shakai
     
  7. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hi

    Dann liegt es eindeutig an der httpd.conf

    Setz die Parameter doch mal an das Ende der Datei und schau was passiert.
    Debuggen kannst Du mit

    sudo apachectl configtest


    HTH

    W
     
  8. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    Verstehe nicht direkt was du meinst, sry.
    Bzw. wenn ich es verstanden habe, dann geht's nicht, habe ein bisschen herumprobiert.:rolleyes:

    Bis dahin

    Schöne Grüsse

    Shakai
     
  9. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hi

    Okay, das war ein wenig schludrig formuliert.

    Setz mal die Zeilen

    DAVLockDB /Library/WebServer/davlocks/DAVLockDB
    DAVMinTimeout 600

    an das Ende der httpd.conf

    (natürlich müssen die dann an der bisherigen Stelle gelöscht werden)

    und teste die Konfiguration mit

    sudo apachectl configtest

    Die siehst mögliche Fehler dann im Terminal

    Wenn das alles nicht hilft, schick mir mal den Text der httpd.conf via PM

    W
     
  10. Shakai

    Shakai Thread Starter MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    27.02.2002
    Hat nicht geklappt! Er zeigt dann den gleichen error an bloß halt:
    <location not allowed here

    Ich schicke dir meine komplette httpd.conf mal zu.

    Danke für die Hilfe

    Shakai
     
Die Seite wird geladen...