HTML auf Mac programmiert, auf Windows nicht richtig dargestellt

Dieses Thema im Forum "Web Page Design" wurde erstellt von pilot.aev, 10.03.2006.

  1. pilot.aev

    pilot.aev Thread Starter MacUser Mitglied

    Beiträge:
    2
    Zustimmungen:
    0
    MacUser seit:
    10.03.2006
    Ich habe erst kürzlich auf Mac umgestellt. Bin übrigens begeistert, parktisch keine Nachteile...

    Zurück zu meinem Problem:

    Ich habe mir eine Website mit HTML-Code programmiert, aufgeschaltet auf dem Mac funktioniert sie wunderbar, aber auf allen PC mit Windows kann die Page nicht richtig dargestellt werden. Könnt ihr mir helfen? Was muss ich tun, damit auf Windowscomputern die Page richtig angezeigt wird?

    Danke,
    schon im Voraus
     
  2. Ulfrinn

    Ulfrinn MacUser Mitglied

    Beiträge:
    6.676
    Zustimmungen:
    586
    MacUser seit:
    30.01.2005
    Meistens hilft es, gültiges HTML zu schreiben. Gelegentlich muß man allerdings Eigenheiten des Internet Explorers berücksichtigen. SelfHTML bietet dir einige Informationen, auch dazu, wie es die einzelnen Navigatoren es mit den Standards halten.
     
  3. MacEnroe

    MacEnroe MacUser Mitglied

    Beiträge:
    15.978
    Zustimmungen:
    1.392
    MacUser seit:
    10.02.2004
    Da kann dir keiner helfen ohne weitere Angaben. Kannst du den Quellcode als Anhang hier posten oder einfach den Link auf die Webseite? Dann ist das Problem sicher schnell erkannt.
     
  4. KonBon

    KonBon MacUser Mitglied

    Beiträge:
    4.921
    Zustimmungen:
    20
    MacUser seit:
    11.02.2003
    HTML programmiert man nicht.

    Hast du die Website den W3C tauglich geschrieben?
    Wenn ja, hast du die unter Windows in andere Browser als den IE getestet?
     
  5. pilot.aev

    pilot.aev Thread Starter MacUser Mitglied

    Beiträge:
    2
    Zustimmungen:
    0
    MacUser seit:
    10.03.2006
    Also meine Page heisst: pilot.aev.ch.vu
    meiner Meinung nach ist W3C geschriben.

    Wenn ich mich irgendwie falsch ausgedrückt habe, tut mir leid, bin kein profi nur ein Laie.
     
  6. Ulfrinn

    Ulfrinn MacUser Mitglied

    Beiträge:
    6.676
    Zustimmungen:
    586
    MacUser seit:
    30.01.2005
    Der Prüfer des W3-Konsortiums meldet mir einige Fehler. Die solltest du zunächst einmal beseitigen. Deine home.htm kann er beispielsweise gar nicht prüfen, weil eine falsche Kodierung angegeben ist. Und ich habe auch keine Lust, da alles mögliche durchzuprobieren. Nimm dich einfach meines Hinweises an, dich bei SelfHTML einzulesen. Dann klappt’s auch mit Windows.
     
  7. KonBon

    KonBon MacUser Mitglied

    Beiträge:
    4.921
    Zustimmungen:
    20
    MacUser seit:
    11.02.2003
    Hast du die unter Windows auch unter anderen Browsern getestet als den IE?
    Wenn nein, tu dieses mal. Der IE zeigt oft einiges falsch an.
     
  8. moses_78

    moses_78 MacUser Mitglied

    Beiträge:
    1.322
    Zustimmungen:
    22
    MacUser seit:
    08.04.2005
    Ich muss gestehen, mir die Seite nicht angesehen zu haben, aber die Dar-
    stellung des Internet Explorers und zb. die des Firefox' am Mac unterschei-
    det sich in einigen Bereichen. Sieh dir mal diesen Faden an, wo einige Feh-
    ler des Internet Explorers aufgelistet sind ;)
     
Die Seite wird geladen...

Diese Seite empfehlen