Hilfe! Startproblem mit 2. HD in G3 Desktop

Dieses Thema im Forum "Mac Pro, Power Mac, Cube" wurde erstellt von Snoere, 17.09.2003.

  1. Snoere

    Snoere Thread Starter MacUser Mitglied

    Beiträge:
    161
    Zustimmungen:
    0
    MacUser seit:
    07.09.2003
    Hallo,

    wir haben eine G3 Desktop mit 6GB-Platte und am zweiten IDE-Kanal eine IBM 46GB-Platte. Das funktionierte bisher ohne Probleme. Auf der 1. Platte ist jetzt OS X installiert. Die zweite Platte wurde mit einem Testprogramm von IBm getestet und low-level formatiert, da es sich um ein Modell aus der berüchtigten Fehlerserie handelt. Die Platte wurde von OS X aus partitioniert und formatiert. Bis dahin keine Probleme.
    Wir haben aber inzwischen festegestellt, dass wir mehr Speicherplatz benötigen. Also habe ich auf die erste Partition auf der 2. Platte (4GB) ebenfalls OS X installiert, um die 6GB-Platte bald durch die 46GB zu ersetzen (+ eine noch zu erwerbende 120GB).
    Beim Hochfahren kommt jetzt immer die Diskette mit dem Fragezeichen. Jede Platte einzeln läßt sich booten, aber zusammen klappt es nicht.
    Was ich bisher versucht habe:
    - NVRAM mehrmals zurückgesetzt (auch in der OpenFirmware)
    - Jumper auf korrekte Master/ Slave-Settings überprüft
    - auf der 46er die OS X-Partition gelöscht
    - Booten mit gedrückter X-Taste
    - Booten mit gedrückter WAHL-Taste
    - Nur mit der 6GB gebootet und diese als Startvolume definiert
    Alles ohne Erfolg.
    Für mich sieht es so aus, als ob der arme Mac sich beim Booten nicht mehr entscheiden kann. Der ganze Aufwand ist auch nur, um vor dem Kauf einer neuen Platte erst mal den Server-Betrieb unter OS X Client zu testen. Deshalb sollen doch nochmal beide Platten eingebaut sein.

    Woran kann es liegen? Ich komme einfach nicht weiter.
    Gruß
    Snoere
     
  2. Snoere

    Snoere Thread Starter MacUser Mitglied

    Beiträge:
    161
    Zustimmungen:
    0
    MacUser seit:
    07.09.2003
    Nachtrag: es wird schlimmer!

    Hallo,

    das Problem hat sich verschärft. Vorhin konnte der Rechner von der einzelnen interenen Platte noch booten. Jetzt klappt das auch nicht mehr (2. Platte ist wieder entfernt!).
    Wer weiß was da schief läfut/ gelaufen ist?
    Warum findet das Festplattenhilfsprogramm der OS X-CD auf einer frischen Installation haufenweise Fehler in der Zugriffsberechtigung?
    Es gibt sogar Dinge, die gehen auf einem PC tatsächlich viel einfacher...
    Gruß
    Snoere
     
  3. Was meinst Du mit "am zweiten IDE-Kanal"?

    P.S. Das ReadMe hast Du gelesen?

    Installieren auf einem Computer der PowerBook G3 Serie, einem Original Power
    Macintosh G3 oder einem iMac
    Wenn beim Auswählen des Zielvolumes die Nachricht angezeigt wird, dass Sie Mac OS X
    auf einer Partition installieren müssen, die sich vollständig innerhalb der ersten 8GB der
    Festplatte befinden, wählen Sie „Festplatten-Dienstprogramm öffnen“ aus dem Menü
    „Installer“. Klicken Sie dann in „Partitionieren“, um die Partitionen Ihrer Festplatte anzuzeigen.
    Die erste Partition befindet sich ganz oben. Wählen Sie sie aus und vergewissern
    Sie sich, dass sie 8GB oder kleiner ist.
    Wenn die erste Partition größer als 8GB ist oder wenn Ihre Festplatte nur eine Partition
    besitzt, die größer als 8GB ist, müssen Sie Ihre Festplatte zunächst erneut partitionieren.
    Durch die Partitionierung wird die komplette Festplatte gelöscht. Stellen Sie daher
    unbedingt sicher, dass alle noch benötigten Dateien gesichert sind, bevorSie die Festplatte
    löschen.
     
  4. Snoere

    Snoere Thread Starter MacUser Mitglied

    Beiträge:
    161
    Zustimmungen:
    0
    MacUser seit:
    07.09.2003
    Antwort und neue Fragen

    Hallo ut,

    ja, das readme habe ich gelesen. Die OS X-Partition ist 3GB und liegt am Anfang.
    Der zweite IDE-Kanal ist der Anschluss an dem auch schon das CD-ROM hängt. Der Plattenzugriff hat es ja zuerst alles geklappt, auch schon vorher unter OS 9.
    Für mich ist die Hauptfrage, warum er plötzlich von der 6GB-Platte nicht mehr booten kann, obwohl es vorhin noch funktioniert hat. Da half wirklich kein Trick, keine HD-Überprüfung/ Reparatur mit dem Dienstprogramm der OS X-Install-CD (10.2).
    Durch den (Wieder-)Einbau der zweiten Platte ging plötzlich die Bootfähigkeit verloren. Ich will den Grund verstehen, damit mir das nicht nochmals passieren kann, falls wir uns für eine neue großé Platte entscheiden.
    Wie erkennt ein Mac, von welcher Platte er booten kann? Wo liegt die bootinfo und was steht da drin? Wer schreibt die bootinfo? Das OS, ein Hilfs-Programm?
    Ich installiere gerade das OS X neu, aber dadurch verliere ich natürlich meine Updates...
    Jetzt bootet er wieder von der Platte, auch wenn die zweite eingebaut ist. Aber wo lag jetzt das Problem?
    Gruß
    Snoere
     
  5. Bezüglich der Frage nach der Bootinfo: http://www.macuser.de/forum/showthread.php?s=&threadid=5949#post31983

    Ein Bekannter von mir hatte mal ein ähnliches Problem mit einen G3beige RevA. Da lag es am nicht originalen CD-ROM-Laufwerk, dass beim initialisieren des IDE-Busses Probleme gemacht hat. Ich vermute mal, dass Deiner auch so ein G3 beige RevA ist (obwohl, wenn Du zwei Geräte an einem IDE-Bus betreiben kannst, dann ist es mindestens ein RevB:confused:)
    Der G3 beige ist bekannt dafür, dass er Probleme mit OS X hat. Dass die beigen G3 überhaupt offiziell unterstützt werden, ist eine reine Marketingentscheidung. Die beigen G3 entsprechen nämlich von der Firmware den älteren Modellen, die von Mac OS X nicht untertstützt werden. Apple musste da einiges patchen mittels nvramrc-Datei, damit es überhaupt funktioniert:
    Beim Start von Mac OS X wird die Firmware gepatcht mit einem Script in der Datei /usr/share/nvram/Gossamer. Dabei wird u.a. der ATA-Bus zurückgesetzt und auf Drive-Select eingestellt. Der enstprechende Ausschnitt aus dem nvramrc sieht so aus:

    dev ide0\
    : open use-ata-interface 0 &c -1 ;\
    : set-device-ID set-drive-select ;\
    : reset-atapi-bus reset-ata-bus ;\
    ' reset-ata-bus 2c + ' 2 $L\
    $E\

    (desgleichen für den anderen IDE-Bus)
    Dabei treten dann offensichtlich die von Dir geschilderten Probleme auf. Der ATA-Bus, der sich beim patchen aufgehängt hat, lässt dann auch keinen Zugriff die andere Platte mehr zu. Der Eintrag use-nvramrc wird beim NV-RAM-Reset nicht auf false gesetzt.

    Eventuell funktioniert es ja mit XPostfacto, das patcht auch die Firmware, aber halt anders.


    Das das Festplatten-Dienstprogramm haufenweise Fehler bei den Zugriffsrechten findet, kann daran liegen, dass die Platte mit der Option Zugriffsrechte ignorieren gemountet wird. Dann denkt das Festplatten--Dienstprogramm, der Eigentümer sei 501(statt 0). Das stimmt aber nur für das Dateisystem, das in das RAM geladen wurde, das auf der Festplatte hat die richtigen Zugriffsrechte.
     
  6. Snoere

    Snoere Thread Starter MacUser Mitglied

    Beiträge:
    161
    Zustimmungen:
    0
    MacUser seit:
    07.09.2003
    Wow! Danke für die vielen Infos!

    Hallo ut,

    jetzt läuft das Schnuckelchen wieder. Die Neuinstallation hat es wieder hingekriegt (mit beiden Platten). Aber mir wäre schon wohler, wenn ich das Problem genau eingrenzen könnte, damit mir beim geplanten Einbau der großen Platte nicht nochmals das selbe passiert.
    Der Rechner ist laut den Infos auf http://www.xlr8yourmac.com/ mindestens Rev B, so weit bin ich schon. XPostFacto werde ich mir mal genauer anschauen. Hast du vielleicht auch noch ausführlichere Links zur OpenFirmware? Bei AppleDeveloper habe ich drei Grundlagenartikel gefunden (PCI, DeviceTree, CLI), die mir aber noch nicht genug Informationen gegeben haben (bzw. teilweise zuuuuu speziell für mich waren). Mir geht es eher um den praktischen Umgang. Wie ziehe ich mir Infos aus der OF? Wie nutze ich das im Alltag?
    Der von dir verlinkte Thread wird jedenfalls gespeichert. Da stecken ja jede Menge Infos und Links drin.

    Ich zweifele gerade noch etwas an der Initalisierungstheorie. Die Platten haben ja zuerst ganz gut zusammen funktioniert. Jetzt nach einer Neuinstallation des Systems geht es auch wieder. Also mir scheint, dass das System (aus irgend einem Grund) an den Bootdateien was verändert hat (Pfad?). Es ist auf jeden Fall eine Geschichte die vom Festplatten-Hilfsprogramm nicht gelöst werden kann, sondern erst von einer Neuinstallation korrigiert wird. Aber ich bin erst seit zwei Tagen im Kontakt mit OS X und habe von den Vorgängen und Problemen beim Booten erst eine "zarte" Ahnung.

    Jetzt bin ich aber nochmals über das "DriveSelect" gestolpert. Aber nach meinen Kenntnissen dürfte das sich doch nicht mit einer festen Master/ Slave-Zuweisung durch Jumper beißen, oder?
    Gruß
    Snoere
     
Die Seite wird geladen...

Diese Seite empfehlen