Gentoo Portage "emerge system" Problem

Diskutiere mit über: Gentoo Portage "emerge system" Problem im Linux auf dem Mac Forum

  1. Galdo

    Galdo Thread Starter MacUser Mitglied

    Beiträge:
    590
    Zustimmungen:
    0
    Registriert seit:
    29.09.2004
    Hallo,

    ich habe mich genau an die Anleitung gehalten, die im Netz zur Portage Installation auf Macos 10.3 zu finden ist.

    Leider habe erhalte ich nach einem "emerge system" folgenden Fehler:

    iBook-Galdo:/Users/galdo root# emerge system
    Calculating system dependencies /
    !!! All ebuilds that could satisfy "sys-apps/coreutils" have been masked.
    !!! One of the following masked packages is required to complete your request:
    - sys-apps/coreutils-5.0-r6 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.0-r2 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1-r1 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1-r2 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1 (masked by: missing keyword)

    For more information, see MASKED PACKAGES section in the emerge man page or
    section 2.2 "Software Availability" in the Gentoo Handbook.
    !!! (dependency required by "sys-apps/debianutils-1.16.7-r4" [ebuild])


    !!! Problem with ebuild sys-apps/debianutils-1.16.7-r4
    !!! Possibly a DEPEND/*DEPEND problem.

    !!! Depgraph creation failed.​

    Wäre nett,

    wenn mir jemand einen Tipp geben könnte!

    Vielen Dank

    Galdo
     
  2. Rakor

    Rakor MacUser Mitglied

    Beiträge:
    2.785
    Zustimmungen:
    3
    Registriert seit:
    05.11.2003
    Servus in Mannem :)

    Naja er sagt dir, dass coreutils gemasked ist... Hast du den portagetree aktualisiert?
     
  3. Galdo

    Galdo Thread Starter MacUser Mitglied

    Beiträge:
    590
    Zustimmungen:
    0
    Registriert seit:
    29.09.2004
    Wie gesagt, ich hab mich genau an die Anleitung gehalten und hab dementsprechend auch ein "emerge sync" durchgeführt.

    Bin aber gerade am probieren, und mache nochmal ein sync. Vielleicht klappts ja dann :)

    Ich will den gentoo-portage :p (auf x86 läufts ja auch)
     
  4. Rakor

    Rakor MacUser Mitglied

    Beiträge:
    2.785
    Zustimmungen:
    3
    Registriert seit:
    05.11.2003
    Tja, ich hab mit Portage auf PPC auch keine Erfahrung... aber bei allen installationen auf x86 ist es bisher anstandslos gegangen...

    Installierst du nur das Portage für OSX oder ein Gentoo? AFAIK ist Portage für OSX noch in Entwicklung... evtl solltest du überlegen ob du masked Packete erlaubst (wenn es eh nur mal zum Test ist).

    BTW: Was sagt denn ein

    $ emerge -p system

    ?
     
    Zuletzt bearbeitet: 19.11.2004
  5. ignatz

    ignatz MacUser Mitglied

    Beiträge:
    225
    Zustimmungen:
    2
    Registriert seit:
    02.06.2004
    ich mein ich kenn mich jetzt auch nicht so super mit portage auf OSX aus, aber ich würd jetzt einfach mal aus alter gewohnheit vorschlagen:

    echo "sys-apps/coreutils" > /etc/portage/package.unmask
    echo "sys-apps/coreutils ~macos" > /etc/portage/package.keywords

    letzteres nurfalls entsprechendes keyword überhaupt existiert, als ich mir das vor Monaten mal angeschaut hatte, gabs selbiges eben noch nicht. Ansonsten kann man sich teilweise auch mit ~ppc abhelfen (sollte man aber nicht übertreiben, da man gefahrläuft sich in den depencies zu verfangen)
     
  6. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.774
    Zustimmungen:
    3.629
    Registriert seit:
    23.11.2004
    probier doch einfach mal ein "emerge -i" auf eins der sys-apps/coreutils pakete deiner wahl
     
Die Seite wird geladen...
Ähnliche Themen - Gentoo Portage emerge Forum Datum
Config bei Gentoo auf Alu iMac Linux auf dem Mac 25.11.2007
Gentoo Linux - Problem mit /etc/fstab Linux auf dem Mac 13.03.2006
Gentoo auf dem G5 ? Linux auf dem Mac 27.02.2006
Gentoo Booted nicht Linux auf dem Mac 14.10.2005

Diese Seite empfehlen

Benutzerdefinierte Suche