Funktionierender Austausch von Tex(t)files, etc.?

Dieses Thema im Forum "Office Software" wurde erstellt von misterbecks, 01.06.2006.

  1. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Welche Einstellungen bei der Kodierung sollte man wählen, damit es beim Austausch von .tex, .txt, etc. Files mit Win-Usern keine Probleme gibt?
     
  2. milchschnitte

    milchschnitte Banned

    Beiträge:
    1.313
    Zustimmungen:
    0
    MacUser seit:
    08.10.2005
    die einzige möglichkeit, textfiles auszutauschen, bei denen zeilenumbrüche, umlaute und sonstiges 100%ig stimmen die mir bekannt ist: text in der code-ansicht von dreameaver schreiben und als *.txt abspeichern. hab vorher lange nach einer komfortableren möglichkeit gesucht, aber keine andere gefunden. gab immer nen haken.
     
  3. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Sicher eine Möglichkeit, dazu braucht man aber Dreamweaver. Ich schreibe die .tex Files z.B. mit TeXShop, da könnte ich doch eigentlich nur mit Latin 1 arbeiten, oder?
     
  4. Biberbeat

    Biberbeat MacUser Mitglied

    Beiträge:
    116
    Zustimmungen:
    0
    MacUser seit:
    24.05.2006
    @Milchschnitte: das wichtigste hast du vergessen. In welcher Kodierung hast du in Dreamveaver gearbeitet?

    Also ich habe TeX-Files immer mit Latin 1 kodiert, das konnte problemlos mit Windowsusern ausgetauscht werden.
     
  5. msslovi0

    msslovi0 MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    MacUser seit:
    20.03.2005
    SubEthaEdit wandelt problemlos in beliebige Kodierungen und Umbrüche. Latin 1 und CRLF ist auf Windows-Systemen üblich.

    Matt
     
  6. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Ok, aber jetzt kommt die Steigerung:

    Ich kodiere das TeX-File mit Latin 1 (bzw. bekomme so ein File von einem Win-User), erstelle daraus ein .Snw und sweave es mit R wieder zu einem TeX-File. In der Präamble steht:

    \usepackage[T1]{fontenc}

    Trotzdem funktioniert es nicht und ich erhalte z.B. ö anstatt dem Ö.

    Woran kann das liegen?
     
  7. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Um den Thread sinnvoll abzuschließen: Mittlerweile habe ich alle Files, die ausgetauscht werden, auf UTF-8 umgestellt. Damit gibt es auf keinem anderen OS Probleme.....hoffentlich.
     
Die Seite wird geladen...

Diese Seite empfehlen