Farbunterschied bei .gif, .jpg und .png

Dieses Thema im Forum "Bildbearbeitung" wurde erstellt von heldausberlin, 02.02.2006.

  1. heldausberlin

    heldausberlin Thread Starter MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    Registriert seit:
    01.05.2004
    Konnte nichts drüber finden.

    Wenn ich eine Grafik in einer Website (ohne transparenten Hintergrund) einbetten möchte und die Hintergrundfarbe der Grafik die gleiche sein soll, wie der Hintergrund der Website, wieso geht das dann nur mit .gif-Grafiken?

    Wenn es an der Anzahl an Farben liegt, ist mir klar, dass .jpg und .png (24bit) das anders darstellen. Aber .png (8bit) zeigt auch einen Farbunterschied?

    Kann mir das jemand erklären?

    Danke.
     
  2. ostersau

    ostersau MacUser Mitglied

    Beiträge:
    780
    Zustimmungen:
    0
    Registriert seit:
    27.06.2005
    Woran es genau liegt, kann ich auch nicht sagen.
    Aber vielleicht ein Vorschlag zur Problemlösung:
    Du kannst im "für web Speichern"-dialog bei GIF und PNG8 bestimmen, dass eine Farbe beim Speichern fixiert bleibt. Mit der Pipette auswählen und dann auf das kleine Schloss unter der Anzeige der Farben klicken. Somit sollte sie beim Speichern erhalten bleiben.
     
  3. heldausberlin

    heldausberlin Thread Starter MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    Registriert seit:
    01.05.2004
    Jau, aber genau das geht nicht bei png8. Da fällt der Farbton immer anders aus :(
     
  4. MacEnroe

    MacEnroe MacUser Mitglied

    Beiträge:
    15.964
    Zustimmungen:
    1.392
    Registriert seit:
    10.02.2004
    Wenn ich bei JPG in RGB für den Hintergrund eine web-sichere Farbe nehme, dann klappt das, soweit ich weiß schon. Muss eben ein Web-Farbe sein.
     
  5. heldausberlin

    heldausberlin Thread Starter MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    Registriert seit:
    01.05.2004
    Auch das komischer Weise nicht. :(
     
  6. xlqr

    xlqr MacUser Mitglied

    Beiträge:
    1.943
    Zustimmungen:
    15
    Registriert seit:
    08.09.2003
    eine antwort habe ich auch nicht (ich vermute es hat mit der art der browser jpgs und pngs zu rendern zu tun) - aber einen workaround ;)

    in ähnlichen fällen mach ich aus der gewünschten hintergrundfarbe ein 1x1 oder 5x5 px grosses *.jpg oder *.png und leg selbiges als hintergrundbild in den body …
     
  7. MacEnroe

    MacEnroe MacUser Mitglied

    Beiträge:
    15.964
    Zustimmungen:
    1.392
    Registriert seit:
    10.02.2004
    Mach ich auch.
    Aber lieber mindestens 10 x 10 oder 100x100 Pixel. Das baut der Browser schneller auf. Bei 1x1 Pixel braucht z.B. der Netscape ewig.
     
  8. heldausberlin

    heldausberlin Thread Starter MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    Registriert seit:
    01.05.2004
    Coole Idee! Danke. :)
     
  9. ThoRic

    ThoRic MacUser Mitglied

    Beiträge:
    2.602
    Zustimmungen:
    179
    Registriert seit:
    13.02.2005
    Hallo,

    seit Tiger und Safari ist damit Schluss.

    Ich hab die obige Konstellation jetzt nicht durchgetestet, aber nach meinen bisherigen Erfahrungen dürfte das folgendermassen laufen:

    HG wird unkompensiert angezeigt.
    JPEG ohne Profil wird als DefaultRGB angezeigt (ähnlich sRGB aber nicht gleich).
    JPEG mit Profil wird entsprechend den Profilvorgaben dargestellt.

    Somit wäre für Safari ein DefaultRGB JPEG die Lösung, aber das funktioniert weder im FF, noch im Explorer und unter Win erst recht nicht

    MfG

    ThoRic
     
  10. heldausberlin

    heldausberlin Thread Starter MacUser Mitglied

    Beiträge:
    14.081
    Zustimmungen:
    302
    Registriert seit:
    01.05.2004
    Dann ist es auch überflüssig.
     
Die Seite wird geladen...

Diese Seite empfehlen