externe HD-Partition kann nicht gemountet werden

Diskutiere mit über: externe HD-Partition kann nicht gemountet werden im Mac OS X Forum

  1. BCN

    BCN Thread Starter MacUser Mitglied

    Beiträge:
    6
    Zustimmungen:
    0
    Registriert seit:
    03.05.2004
    Hallo Zusammen,

    habe mir an meiner neuen externen HD (USB), die ich nach dem u.a. hier

    http://www.macuser.de/forum/showthread.php?t=90443

    vorgeschlagenen Schema in 2 systemverschiedene Partitionen aufgeteilt habe , meine Mac-Partition zerschossen.
    Auf der ganzen Platte sind glücklicherweise noch keine Daten drauf, da mir der “Unfall” noch in der Vorbereitung passiert ist. Leider ist die kaputte Partition jedoch für mich nicht mehr benutzbar, d.h. obwohl der Mac sie im Terminal noch erkennt, mountet er sie nicht. Auch manuelles Mounten über das Festplattendienstprogramm funktioniert nicht. Da ich leider kein HD-Profi bin, wie ich leider feststellen musste ;), weiss ich nicht mehr weiter:

    die neue HD hat laut Terminal/ diskutil 76,7 GB; die habe ich in eine Partition mit HFS+ ( 31,7 GB) u. in eine Partition mit FAT32 (45 GB) aufgeteilt. Hintergrund war, dass ich zum einen für mein iBook (20 GB, OS X 10.3.9) ein bootfähiges Backup-medium erstellen- und zum anderen den restlichen Speicherplatz mit dem PC meiner Frau nutzen wollte.

    Das Partitionieren selbst ging dank der sehr guten Anleitung von Willfried (großes Lob auch noch mal an dieser Stelle!) auch ohne Probleme. das iBook mountete beide Partitionen nebeneinander.

    Dann der erste Backup-Versuch am iBook mit “Silver Keeper”; der blieb nach gut 400 MB hängen, d.h. die externe HD hörte auf, zu schreiben. Das Programm (Silver Keeper) checkte anfangs noch weitere Daten ein, als die aber nicht mehr geschrieben wurden bremste es aber ab und reagierte bald nicht mehr; OS X reagierte auch nur noch mit extremer Verzögerung. Erst nachdem ich die externe HD ausgeschaltet habe, fing sich der Mac wieder und ich konnte den Silver-Keeper von Hand abbrechen.
    Nachdem ich die bereits übertragenen Daten von Hand von der Backup-Partition gelöscht hatte machte ich einen zweiten Versuch. Jetzt blieb der Backup allerdings schon bei ca. geschriebenen 50 MB auf der externen HD stehen. Zur Wiedererlangung des Systems dasselbe Prozedere (externe Platte abschalten, Programm manuell abbrechen etc.) ??!!!

    1. Frage: woher kommt dieses Verhalten beim Backup? Sind das Treiber-Fehler oder so etwas? Ich hatte nämlich die Platte vorher zu Versuchszwecken (unpartioniert u. mit Originalformatierung) am PC angeschlossen gehabt und ohne Probleme ein über 30 GB großes Backup darauf erstellt. ich gehe daher davon aus, dass kein Hardware-Fehler vorliegt.

    Die Platte ist übrigens ein “GStor Secure Mobile Storage USB 2.0” (3,5 Zoll)

    Mittlerweile habe ich aber noch ein anderes, fast noch unangenehmeres Problem, weswegen ich eigentlich hier poste:

    Da die Platte ja noch neu, d.h. ohne wichtige Daten darauf war und meine Experimentierfreudigkeit mit mir durchging (was man nicht gelernt hat, sollte man manchmal wohl besser lassen), bin ich ins Festplattendienstprogramm und habe kurzerhand die HFS+-Partition gelöscht. Dabei ist die externe HD aber wieder hängengeblieben, d.h. der Löschvorgang wurde nicht ordnungsgemäß abgeschlossen. und das System bremste wieder bis (fast) zum Stillstand. Nach dem Ausschalten der Festplatte und Wiederanschalten wurde nun die HFS+-Partition nicht mehr gemountet. Im Festplattendiensprogramm ist sie zwar weiterhin sichtbar, mit HD-Symbol unter der eigentlichen externen HD. Sie lässt sich aber nicht mounten bzw. der entsprechende Button bleibt inaktiv. Auch Formatieren oder Wiederherstellen dieser Partition geht im Festplattenprogramm nicht. Die FAT32-Partition dagegen wird wie vorher gemountet und erkannt.

    Mittlerweile habe ich bereits mehrmals versucht, die ursprüngliche Partitionierung im Terminal erneut vorzunehmen. Allerdings komme ich nur noch bis zum Befehl

    “diskutil enableJournal <Identifier>“

    den führt er nicht mehr aus, stattdessen sagt er “The selected journaling request does not appear to be valid”


    Auch ein mehrmaliiges Powercyclen der externen HD brachte keine Änderung. Die MAc-Partition bleibt unmountbar. Was auffiel ist allerdings, dass das iBook sich jedesmal beim Herunterfahren aufhängt, wenn vorher die externe HD im gegenwärtigen Zustand angeschlossen war – egal ob die derzeit einzig im Finder sichtbare FAT-Partition vorher ordnungsgemäß durch Auswerfen unmounted wurde oder die Platte ohne Auswerfen einfach abgetrennt wird.

    daher meine

    2. Frage: gibt es eine einfache Möglichkeit die kaputte HFS+-Partition entweder wiederherzustellen oder aber die ganze externe HD inklusive aller Partitionen und –Reste “plattzumachen”, um nocheinmal von vorne mit der Partitionierung etc. zu beginnen?

    wie gesagt, einfaches Wiederholen der diskutil-Routine nach

    http://www.macuser.de/forum/showthread.php?t=90443

    hat keine Abhilfe geschaffen.

    Nach längerem Googlen und Suchen vermute ich, dass es wohl irgendetwas mit einem defekten Bootsektor oder mit Fehlern in der Partitionstabelle zu tun hat. Wie man damit umgeht bzw. wie so etwas behoben werden kann, geht aber definitiv über meine EDV-Kenntnisse.

    Anbei nochmal ein aktuelles paste aus dem Terminal nach “diskutil list”:

    “ ..
    /dev/disk0
    #: type name size identifier
    0: Apple_partition_scheme *18.6 GB disk0
    1: Apple_partition_map 31.5 KB disk0s1
    2: Apple_Driver43 27.0 KB disk0s2
    3: Apple_Driver43 37.0 KB disk0s3
    4: Apple_Driver_ATA 27.0 KB disk0s4
    5: Apple_Driver_ATA 37.0 KB disk0s5
    6: Apple_FWDriver 100.0 KB disk0s6
    7: Apple_Driver_IOKit 256.0 KB disk0s7
    8: Apple_Patches 256.0 KB disk0s8
    9: Apple_HFS A-Platte 7.9 GB disk0s9
    10: Apple_HFS B-Platte 10.8 GB disk0s10
    /dev/disk1
    #: type name size identifier
    0: FDisk_partition_scheme *76.7 GB disk1
    1: Apple_HFS 31.7 GB disk1s1
    2: DOS_FAT_32 D2 45.0 GB disk1s5
    ...”


    wie gesagt, die hier problematische Partition auf der als "disk1" gefundenen externen HD wird nach wie vor unter “disk1s1” gelistet, obwohl sie nicht mehr gemounted werden kann.

    Falls mir jemand sagen kann, wie ich den Screenshot machen muss würde ich gerne auch mal die Ansicht im Festplattendienstprogramm posten.

    Für den Fall, dass ich das mit der Partition wieder hinbekomme bleibt mir ja immer noch das Rätsel der abbrechenden Schreibvorgänge beim Backup zu lösen.......:confused:

    Vielen Dank im voraus für alle Tipps und Hinweise
     
  2. Ren van Hoek

    Ren van Hoek MacUser Mitglied

    Beiträge:
    5.767
    Zustimmungen:
    102
    Registriert seit:
    18.08.2004
    Hi,
    Screenshot des ganzen Bildschirms: apfel + shift + 3
    Screenshot ausgewählt: apfel + shift + 4

    das "plattmachen" im Festplattendienstprogramm geht auch nicht?
     
    Zuletzt bearbeitet: 11.01.2007
  3. BCN

    BCN Thread Starter MacUser Mitglied

    Beiträge:
    6
    Zustimmungen:
    0
    Registriert seit:
    03.05.2004
    Fehler (-9972) im Festplattendienstprogramm

    Hallo,

    danke für die Screenshot-Nachhilfe.

    Nein, im Festplattendienstprogramm "killt" er wenn nur die 2. (Win-)Partition; die kaputte HFS-Partition bleibt immer (grau) und da

    hier mal ein Auszug aus dem Terminal. Wie Du siehst, werden da beide (auf /disk1) ohne weiteres erkannt:

    /dev/disk0
    #: type name size identifier
    0: Apple_partition_scheme *18.6 GB disk0
    1: Apple_partition_map 31.5 KB disk0s1
    2: Apple_Driver43 27.0 KB disk0s2
    3: Apple_Driver43 37.0 KB disk0s3
    4: Apple_Driver_ATA 27.0 KB disk0s4
    5: Apple_Driver_ATA 37.0 KB disk0s5
    6: Apple_FWDriver 100.0 KB disk0s6
    7: Apple_Driver_IOKit 256.0 KB disk0s7
    8: Apple_Patches 256.0 KB disk0s8
    9: Apple_HFS A-Platte 7.9 GB disk0s9
    10: Apple_HFS B-Platte 10.8 GB disk0s10
    /dev/disk1
    #: type name size identifier
    0: FDisk_partition_scheme *76.7 GB disk1
    1: Apple_HFS 32.0 GB disk1s1
    2: DOS_FAT_32 D2 44.7 GB disk1s5


    habe beim vielen rumprobieren im Terminal auch mal eine partition-map rausbekommen. da war relativ deutlich zu sehen, dass es hinten und vorne fehlte: u.a. keinen mount-point etc.

    komme da aber auch nicht mehr hin (entweder Kommando vergessen oder mac erkennt gar keine map mehr) :o


    irgendwelche Ideen
     
Die Seite wird geladen...

Diese Seite empfehlen

Benutzerdefinierte Suche