Excel Sortierung

Diskutiere mit über: Excel Sortierung im Office Software Forum

  1. Mike008

    Mike008 Thread Starter MacUser Mitglied

    Beiträge:
    342
    Zustimmungen:
    0
    Registriert seit:
    30.07.2004
    Hallo Leute,

    ich hab eine Tabelle mit mit folgenden Spalten Vorname,Nachname,Geschlecht,Adresse,Alter. Nun hab ich jeder Spalte einen Autofilter hinzugefügt um beispielsweise nur die männliche Einträge einzusehen.

    Unten hab ich eine Formal diese soll das Durchschnittsalter der männlichen Personen errechnen. Die Rechnung ist einfach aber er soll nur die Zellen auslesen und zusammenzählen von den männlichen. D.h. Er müsste also nur wenn in der Spalte davor ein m (für männlich) steht dann soll das Alter der Zeile ausgelesen und berechnet werden. Er muss also aus der Spalte Geschlecht immer nach m oder w prüfen.

    Ist das möglich ??

    THX Mike
     
  2. autoexec.bat

    autoexec.bat MacUser Mitglied

    Beiträge:
    2.130
    Zustimmungen:
    20
    Registriert seit:
    21.01.2005
    Mir würde da spontan jetzt nur ne Bastellösung mit einer extra Spalte, welche du dann summierst einfallen:

    Angenommen in Spalte A steht m oder w. In Spalte B steht das Alter. Für Spalte C nutzt du dann die Formel (hier für C1):

    =WENN(A1="m";B1;0)

    Wenn du dann Spalte C aufsummierst hast du nur die Männlichen.

    [edit] Nicht gerade die eleganteste Lösung, aber du kannst die Spalten die zusätzlichen Spalten ja ausblenden.
     
  3. Mike008

    Mike008 Thread Starter MacUser Mitglied

    Beiträge:
    342
    Zustimmungen:
    0
    Registriert seit:
    30.07.2004
    Gute Idee, das geht, aber ich versuch es mal mit einem sverweis in einer Matrix. Wenn das nicht klappt dann nehme ich deine Lösung.

    Mike
     
  4. Chromentsorgung

    Chromentsorgung MacUser Mitglied

    Beiträge:
    410
    Zustimmungen:
    0
    Registriert seit:
    07.06.2003
    Probiere gerade etwas mit der if fuktion uas, dauert aber noch einen Moment.
     
  5. Chromentsorgung

    Chromentsorgung MacUser Mitglied

    Beiträge:
    410
    Zustimmungen:
    0
    Registriert seit:
    07.06.2003
    Zu langsam, schade!
     
    Zuletzt bearbeitet: 05.11.2005
  6. Pharell

    Pharell MacUser Mitglied

    Beiträge:
    1.394
    Zustimmungen:
    8
    Registriert seit:
    26.11.2004
    Du kannst Dir auch eine Pivot Tabelle einbauen und Dir dann das Durschnittsalter
    des jeweiligen Geschlechts anzeigen lasssen.
     
  7. Jabba

    Jabba MacUser Mitglied

    Beiträge:
    4.465
    Zustimmungen:
    109
    Registriert seit:
    21.11.2003
    jalapenos Lösung ist schon gut.

    Es geht aber ganz einfach alles zusammen in einer Formel.
    Angenommen in Spalte A steht das Geschlecht, in Spalte B das Alter, dann muss die Formel so aussehen:

    =SUMMEWENN(A1:A1000;"m";B1:B1000)/ZÄHLENWENN(A1:A1000;"m")

    Erst wird die Gesamtsumme errechnet und dann durch die Anzahl geteilt.
    Die Tabellenlänge muss natürlich angepasst werden.
    Gern geschehen.
    HTH
     
  8. giukanis

    giukanis MacUser Mitglied

    Beiträge:
    48
    Zustimmungen:
    5
    Registriert seit:
    19.08.2005
    Hallo,

    wenn ich dich richtig verstehe möchtest du das Durchschnittsalter nur für die "angezeigten" Zeilen berechnen.
    Dafür gibt es die Funktion TEILSUMME(Funktion,Bereich).
    Teilsumme kann auch die Summe von angezeigten (gefilterten) Daten berechnen.
    Für den Durchschnitt musst du Funktion durch "1" ersetzen. Die Summe wird mit "9" berechnet.
    Guck dir am besten dazu einmal die Hilfe an, da werden noch weitere Funktionen beschrieben...

    Gruss
    giukanis.
     
Die Seite wird geladen...
Ähnliche Themen - Excel Sortierung Forum Datum
Excel 2016: Meldung "... Datei XY ist unauffindbar. Kopieren:" Office Software 18.11.2016
Excel, Word oder PP starten dauert eeewig Office Software 18.11.2016
Excel Notendurchschnitt Office Software 11.11.2016
Probleme beim Drucken von Excel-Dateien Office Software 07.11.2016
Sortierung mit Excel Office Software 15.01.2009

Diese Seite empfehlen

Benutzerdefinierte Suche