Embed Real Video

Dieses Thema im Forum "Web Page Design" wurde erstellt von AlCan, 10.10.2006.

  1. AlCan

    AlCan Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    2
    MacUser seit:
    16.10.2005
    Hi Leute

    ich bin ziemlicher HTML Anfänger und hoffe ihr könnt mir helfen.

    Ich muss zwei Real Videos ( ich weiß, ich würde lieber ein anderes Video Format verwenden, aber ist leider Vorgabe) HTML-mäsig einbinden. Hierzu habe ich den Embedded Media HTML Generator verwendet.


    An sich klappt das auch super, nur wenn ich mehr als ein Video einbinden möchte, dann spielen alle eingebundenen Videofenster das gleiche Video ab. Hängt das mit dem Real Player zusammen, oder liegt es am Code?

    Hier der Code:

    <!-- begin embedded RealMedia file... -->
    <table border='0' cellpadding='0' align="left">
    <!-- begin video window... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height="240">
    <param name='src' value="http://servername/path/to/media.file">
    <param name='autostart' value="true">
    <param name='controls' value='imagewindow'>
    <param name='console' value='video'>
    <param name='loop' value="true">
    <EMBED src="http://servername/path/to/media.file" width="320" height="240"
    loop="true" type='audio/x-pn-realaudio-plugin' controls='imagewindow' console='video' autostart="true">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end video window -->
    <!-- begin control panel... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height='30'>
    <param name='src' value="http://servername/path/to/media.file">
    <param name='autostart' value="true">
    <param name='controls' value='ControlPanel'>
    <param name='console' value='video'>
    <EMBED src="http://servername/path/to/media.file" width="320" height='30'
    controls='ControlPanel' type='audio/x-pn-realaudio-plugin' console='video' autostart="true">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end control panel -->
    <!-- ...end embedded RealMedia file -->
    <!-- begin link to launch external media player... -->
    <tr><td align='center'>
    <a href="http://servername/path/to/media.file" style='font-size: 85%;' target='_blank'>Launch in external player</a>
    <!-- ...end link to launch external media player... -->
    </td></tr>


    </table>


    Danke und Grüße

    AL
     
  2. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    Der Player spielt das ab, was als Parameter im Pfad angegeben ist:

    Stehen überall die richtigen Pfade und Dateinamen?

    2nd
     
  3. AlCan

    AlCan Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    2
    MacUser seit:
    16.10.2005
    Ja. Ich habe für die zwei Videos, zwei mal den oben genannten Code, nur mit unterschiedlichen Pfaden. Nur spielt der erste Player seltsamerweise das gleiche wie der zweite, obwohl die Pfade unterschiedlich sind. Lösche ich den zweiten, spielt der erste wieder das richtige. Insgesamt schaut es so aus:

    1.Video
    <!-- begin embedded RealMedia file... -->
    <table border='0' cellpadding='0' align="center">
    <!-- begin video window... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height="240">
    <param name='src' value="http://www.xxx.com/video/la_clip.ram">
    <param name='autostart' value="false">
    <param name='controls' value='imagewindow'>
    <param name='console' value='video'>
    <param name='loop' value="false">
    <EMBED src="http://www.xxx.com/video/la_clip.ram" width="320" height="240"
    loop="false" type='audio/x-pn-realaudio-plugin' controls='imagewindow' console='video' autostart="false">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end video window -->
    <!-- begin control panel... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height='30'>
    <param name='src' value="http://www.xxx.com/video/la_clip.ram">
    <param name='autostart' value="false">
    <param name='controls' value='ControlPanel'>
    <param name='console' value='video'>
    <EMBED src="http://www.xxx.com/video/la_clip.ram" width="320" height='30'
    controls='ControlPanel' type='audio/x-pn-realaudio-plugin' console='video' autostart="false">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end control panel -->
    <!-- ...end embedded RealMedia file -->
    <!-- begin link to launch external media player... -->
    <tr><td align='center'>
    <a href="http://www.xxx.com/video/la_clip.ram" style='font-size: 85%;' target='_blank'>Launch in external player</a>
    <!-- ...end link to launch external media player... -->
    </td></tr>
    </table>

    2.Video

    <!-- begin embedded RealMedia file... -->
    <table border='0' cellpadding='0' align="center">
    <!-- begin video window... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height="240">
    <param name='src' value="http://www.xxx.com/video/la_epk.ram">
    <param name='autostart' value="false">
    <param name='controls' value='imagewindow'>
    <param name='console' value='video'>
    <param name='loop' value="false">
    <EMBED src="http://www.xxx.com/video/la_epk.ram" width="320" height="240"
    loop="false" type='audio/x-pn-realaudio-plugin' controls='imagewindow' console='video' autostart="false">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end video window -->
    <!-- begin control panel... -->
    <tr><td>
    <OBJECT id='rvocx' classid='clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA'
    width="320" height='30'>
    <param name='src' value="http://www.xxx.com/video/la_epk.ram">
    <param name='autostart' value="false">
    <param name='controls' value='ControlPanel'>
    <param name='console' value='video'>
    <EMBED src="http://www.xxx.com/video/la_epk.ram" width="320" height='30'
    controls='ControlPanel' type='audio/x-pn-realaudio-plugin' console='video' autostart="false">
    </EMBED>
    </OBJECT>
    </td></tr>
    <!-- ...end control panel -->
    <!-- ...end embedded RealMedia file -->
    <!-- begin link to launch external media player... -->
    <tr><td align='center'>
    <a href="http://www.xxx.com/video/la_epk.ram" style='font-size: 85%;' target='_blank'>Launch in external player</a>
    <!-- ...end link to launch external media player... -->
    </td></tr>
    </table>
     
  4. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    Dein Object IDs sind gleich:

    OBJECT id='rvocx'

    Und warum bettest Du jedes Video 2x ein?

    2nd
     
  5. AlCan

    AlCan Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    2
    MacUser seit:
    16.10.2005
    Muss die Object ID nicht gleich sein? Es sagt doch aus das es ein Real Player werden soll? Was ist die alternative Object ID?

    Wieso zweimal eingebettet?Es wird einmal das Video, dann die Transportfunktionen und dann der Link zum externen Player eingebettet.

    Danke dir
     
  6. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    Ich dachte, dass die classid der Hinweis für den Real Player als Plugin ist.

    Ich habe jetzt eine halbe Stunde rumprobiert (erstmal so ein beknacktes Real Video zu finden ist eine Kunst) und mit 2 Playern auf der Seite machen die Videos immer dasselbe. Klicke ich irgendwo auf PAUSE, stoppen beide Videos. Das untere zeigt auch nur einen schwarzen Bildschirm.

    Sorry, kann dir wohl nicht weiterhelfen :noplan:

    2nd
     
  7. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    So, ich nochmal: Also mit 2 verschiedenen Videos geht es nach meinen Versuchen nicht.

    Er zeigt bei mir immer nur einen Clip an, der andere Player bleibt schwarz, egal in welcher Reihenfolge und mit welchen Parametern man arbeitet.

    2nd
     
  8. AlCan

    AlCan Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    2
    MacUser seit:
    16.10.2005
    Hm ich probier auch gerade rum, aber es bringt alles nichts, es geht immer nur ein video...

    Aber vielen dank für deine mühen. Ich werde jetzt mal ein US Forum aufsuchen, die haben da glaub ich mehr erfahrung mit diesem drecks format.

    Danke
     
  9. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    Bingo ;)

    2nd
     
Die Seite wird geladen...

Diese Seite empfehlen