E-Mail Textcodierung nervt

Dieses Thema im Forum "Mac OS X" wurde erstellt von Carsi, 20.08.2002.

  1. Carsi

    Carsi Thread Starter MacUser Mitglied

    177
    0
    29.07.2002
    Hallo Macuser,

    ich habe da ein Problem mit dem Mailprogramm von OSX(10.1.5). ich bekomme viele Mails wo immer die üs und äs und ös nicht richtig dargestellt werden. Ich gehe dann immer in Textcodierung, und schalte von Standart auf Mitteleuropäisch. Dann sind alle Umlaute wieder da. Aber nur bei der Mail, die ich gerade lese. Bei jeder neuen Mail muß ich die Textcodierung umschalten, um die Umlaute lesen zu können. Kann man die Textcodierung nicht für alle Mails global einstellen?? Habe nichts gefunden. Über einen Rat würde ich mich sehr freuen.

    Gruß Carsi
     
  2. Andi

    Andi Kaffeetasse

    7.395
    608
    16.05.2002
    Keine Umlaute

    Hallo Carsi,

    ich bin mir da jetzt auch nicht 100%-ig sicher, aber ich glaube das Problem liegt am Absender der E-Mail. Kommen die Mail´s von einem PC?

    Gruß dem Tausender Andi
     
  3. mackurt

    mackurt MacUser Mitglied

    2
    0
    10.03.2002
    Geht noch nicht. Soll mit 10.2 (kostenplichtig:mad: ) behoben werden
     
  4. Marina

    Marina MacUser Mitglied

    328
    0
    28.03.2002
    Hi carsi, andi, mackurt,

    so ganz habe ich es bei der Codierung auch noch nicht geblickt, denn es gibt ganz unzusammenhängend manchmal Mails, denen die Umlaute fehlen. Von PCs abgesendete Mails beinhalten eigentlich immer alles, komischerweise aber die Benachrichtigungen von diesem Webserver macuser.de (FreeBSD, Linux?) sehen dann so aus:

    ---
    In diesem Thema kˆnnten noch weitere Antworten sein, doch solange Du das Board nicht wieder betrittst, bekommst Du keine neuen Benachrichtigungen.
    ---

    In den Apple-Mail-Einstellungen habe ich nur Text angegeben und bisher gab es wenigstens bei den Empfängern keine Beschwerden (vielleicht sind sie ja auch nur höflich und schweigen...)

    Schöne Grüße, Marina
     
  5. mld

    mld MacUser Mitglied

    22
    0
    12.01.2002
    > macuser.de (FreeBSD, Linux?) sehen dann so aus:

    an Linux und FreeBSD liegt's wahrscheinlich eher nicht :) Wir haben das gleiche Problem. Lustige bunte Zeichen, wo eigentlich ein Apostroph oder ein Umlaut sein sollte :)


    Evtl. sind die Seiten und die eMails alle mit CP-850/Windows codiert und der Mac/Unix Browser/Mailer benutzt einen Zeichensatz der für iso-8559-1 bzw 15 für Mitteleuropa codiert ist.

    Abhilfe ist evtl. die Seiten mit den für die Umlaute entsprechenden HTML tags zu versehen, die _alle_ browser anzeigen können, oder mal auszuprobieren ob man nicht irgendwo ein CP-850 Zeichensatz hat.

    Hmmh, bin mir nicht sicher, evtl hilft es auch den sendenden Windowsmailer auf "quoted printable" als Codierung umzustellen. Aber da könnt ich auch falsch liegen.

    Die emails von Mac -> Linux funktionieren übrigens ohne Probleme. :)

    mld
    ---
    uade co dev: http://www.ee.tut.fi/~heikki/uade.html
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  6. Marina

    Marina MacUser Mitglied

    328
    0
    28.03.2002
    Hi mld,

    so ganz habe ich es jetzt nicht verstanden und ich gehe von einem aus, daß die deutsche Übersetzung dieser Forensoftware (Mail-Bsp. s.o.) in Umlauten geschrieben ist. Nun frage ich mich, was passiert mit dem template nach dem Versenden vom Webserver? Meinst Du auf dem Mailweg geschieht die Löschung der Umlaute?

    Die templates direkt zu editieren und ae, oe oder ue, ss einzufügen ginge zwar, ist aber eine ganz schöne Arbeit und dann waere das Problem aus der Welt :)

    Grüße, Marina
     
  7. nagareboshi

    nagareboshi MacUser Mitglied

    260
    0
    20.02.2002
    Re: Re: E-Mail Textcodierung nervt

    merkwürdig. ich hab 10.2 und ewig lange gesucht, aber nichts gefunden. bei mail muss ich immer noch die text kodierung einzelner mails verändern.
     
  8. Marina

    Marina MacUser Mitglied

    328
    0
    28.03.2002
    Hoi,

    solange es nur Servermails sind läßt es sich noch ganz anständig damit leben. Ansonsten mal den physisch realen Absendern 'ne Mahnung schicken :D

    VG, M.
     
  9. mld

    mld MacUser Mitglied

    22
    0
    12.01.2002
    Hej Marina,

    *lach* ja, es lebe US-ASCII ;)

    Leider liegen bei den Codepages nur die Standardbuchstaben an der gleichen Stelle. Umlaute und Sonderzeichen usw liegen bei CP-850 und ISO-8559-1 nicht an der gleichen Stelle.

    Auf manchen Webseiten kann man das zum Beispiel auch sehen, wenn diese auf Win programmiert wurden und keine HTML Steuerzeichen für die Umlaute benutzt wurden.

    Ich denke die meisten Foren sind wahrscheinlich so ausgelegt sein, dass die Sonderzeichen 1:1 so übernommen werden, wie sie der Benutzer eingetippt hat, ohne dass etwas konvertiert wird.
    D.h. wenn jemand mit den Windows Codepages die ä,ö,ü eintippt, werden die Zeichen unkonvertiert angezeigt. Bei mir werden die Postings von dir z.b. korrekt angezeigt. Bei Andis Posting hingegen hab ich ein Z mit einem umgedrehten Dach anstatt eines Apostrophs.

    Lösen liesse sich das evtl. wenn man evtl. über Javascript oder über die HTTP anfragen des Browsers abfragen könnte, welche Kodierung auf dem Rechner benutzt wurde. (Keine Ahnung ob das geht, obwohl man über JS ja ziemlich viel von dem Rechner der auf 'ne Site surft erfahren kann). Jedenfalls könnte man über ein kleines JS/Perl oder ähnliches Script Serverseitig alle Umlaute von einer Codepage oder gar in HTML-Entities konvertieren.

    ö -> ö
    ß ->&szilig;

    usw.


    Bin nicht sicher, was du mit Templates/Vorlagen meinst, daher hoffe ich nicht am Thema vorbei geredet zu haben :)


    @ nagareboshi

    Codepages haben viel mit Zeichensätzen und Ländereinstellungen zu tun. Da ich mich beim Mac leider nicht auskenne, weiss ich leider nicht, ob und wie man das bei OS X global evtl. einstellen kann. Sorry. :(

    mld
     
  10. mld

    mld MacUser Mitglied

    22
    0
    12.01.2002
    *lach* ok, ich brauch manchmal etwas länger. Ich glaub jetzt hab ich verstanden was du mit den templates meintest. Sorry ;)

    Wenn's nur um die Server Benachrichtigungen von macuser.de geht, liesse sich das ganze forumsseitig lösen:

    In eMails wie z.b. "Antwort auf den Beitrag 'E-Mail Textcodierung nervt' müsste die Admins (Vevelt, evtl. eine Aufgabe für dich;) ) einfach in den Mailheader ein paar tags einfügen, das die Kodierung des Textes dem eMailprogramm mitteilt:

    [snip]

    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset=ISO-8859-1

    [snip]

    Das scheint bei den Serverbenachrichtigungen nicht mit angegeben zu sein, und daher scheint der Mac eMail Client irgendwie versuchen zu raten und rät leider falsch ;)


    Zum eigentlichen Problem, wie man global auf Mac-seite die Codepages Lat1 (iso-8859-1) permanent umstellt hab ich leider keinen blassen Schimmer.

    mld
     
Die Seite wird geladen...
Ähnliche Themen - Mail Textcodierung nervt
  1. heischo
    Antworten:
    4
    Aufrufe:
    132
  2. mattmiksys
    Antworten:
    3
    Aufrufe:
    180
  3. ericsson
    Antworten:
    10
    Aufrufe:
    190
    ericsson
    20.09.2016
  4. scampooo
    Antworten:
    4
    Aufrufe:
    246
    scampooo
    13.09.2016
  5. clag
    Antworten:
    8
    Aufrufe:
    146
    JuergenR
    10.09.2016

Diese Seite empfehlen