DISable root user - wo ist es hin?

Diskutiere mit über: DISable root user - wo ist es hin? im Mac OS X Forum

  1. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    Registriert seit:
    18.03.2004
    DISable root user - wo ist es hin? - gelöst

    Hi Folks.

    Im NetInfo Manages kann man ja bekanntlich den root user "enablen" = aktivieren.

    Wenn ich das bisher machte, dann meine ich mich zu erinnern, den user an gleicher Stelle auch wieder "disablen" / deaktivieren zu können. Nach dem letzten SecUpdate (?) steht da unter Security aber auch nach der Aktivierung nur "enable root user".

    Wo kann ich ihn wieder ausknipsen?

    Tx for help, FF

    #############################
    UPDATE 22.9.04 11h20
    #############################

    Habs bei mir gelöst:


    Ich hatte mir einen ftp-User eingerichtet und desse UID und GID im Netinfo Manager auf 499 (statt 502) gesetzt, weil er dann nicht mehr auf der Loginseite als auswählbarer User erscheint.

    Nachdem ich das brav zurückgestellt habe, meldete mir mein System prompt, das root-PW sei zur Zeit blank und ich möge doch eins vergeben. Danach konnte ich auch wieder wie gehabt den root user enablen und disablen, d.h. der Disable-Eintrag war wieder da.

    Jetzt muß ich nur noch wissen, wie ich den ftp-user verberge, ohne root abzuklemmen...

    Cheers, FF
     
    Zuletzt bearbeitet: 22.09.2004
  2. VicDorn

    VicDorn MacUser Mitglied

    Beiträge:
    662
    Zustimmungen:
    0
    Registriert seit:
    06.09.2004
    Hmm, das ist interessant; bei mir ist auch seit kurzem beim Login-Screen das "Weitere..." verschwunden. Im Netinfo Manager kann ich auch root so oft aktivieren, wie ich will, das aendert nichts. Auch ein Rechte reparieren hat nichts geaendert.
    Allerdings ist der root trotzdem aktiviert, denn wenn ich den Login Screen auf Nama/Passwort einstelle und dann "root" und Passwort eingebe, dann logt er ganz normal den root ein. Auch im Terminal kann man mit su ganz normal eine root-shell oeffnen.

    Gruss,

    Stefan
     
  3. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    Registriert seit:
    18.03.2004
    Hi Stefan,

    das ist ja der Punkt, ich will den root user wieder DEaktivieren. Bizzar bizzar....

    FF
     
  4. KAMiKAZOW

    KAMiKAZOW MacUser Mitglied

    Beiträge:
    2.028
    Zustimmungen:
    23
    Registriert seit:
    16.03.2004
    Das scheint ein älteres Problem zu sein. Ich kann den root-User auch nicht über's GUI deaktivieren.
    Der Beitrag http://forums.macosxhints.com/showthread.php?t=17055 ist von 2003.

    EDIT #2: Ah, das sollte die Lösung sein:
    http://forums.macrumors.com/showpost.php?p=914486&postcount=6


    Dann habe ich doch nicht halluziniert. Ich habe den Eintrag nämlich auch nicht, war mir aber zu 90% sicher, dass der vorher mal da war.
    Gut, jetzt weiß ich wenigstens sicher, dass ich mir nichts eingebildet habe.

    EDIT #1: OK, habe etwas gegoogelt und folgendes zu "Weitere..." gefunden: http://docs.info.apple.com/article.html?artnum=25686
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  5. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    Registriert seit:
    18.03.2004

    Das hab ich nicht ganz kapiert, mit dem "authority blahdings". Hab zwar vorher eine rootshell geöffnet, aber da fragte er mich ja bereits nach dem pw. Geändert habe ich nix.

    Wie auch immer, für mich hat sich das Problem ja weitestgehend gelöst (s. Edit im 1. Post).

    Gruß FF
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  6. VicDorn

    VicDorn MacUser Mitglied

    Beiträge:
    662
    Zustimmungen:
    0
    Registriert seit:
    06.09.2004
    (von der Apple Seite)

    Hmm, da muss ich mal wieder gucken - aktiv habe ich da nichts ein- oder ausgestellt, soweit mir bewusst ist. Aber ich lerne das System ja auch erst neu kennen - wenn ich daran denke, wie lange ich gebraucht habe, um Linux so halbwegs zu verstehen... ;-)
     
  7. KAMiKAZOW

    KAMiKAZOW MacUser Mitglied

    Beiträge:
    2.028
    Zustimmungen:
    23
    Registriert seit:
    16.03.2004
    Ah, jetzt hat's bei mir Klick gemacht und peile endlich wo der Fehler liegt. Der Wald, die Bäume .... alte Geschichte. :D

    Also mit Panther hat der Unix-Teil eine Methode bekommen, mit der Passwörter sicherer gespeichert werden (scheint ShadowHash zu heißen). Diese Methode hat auch das Problem behoben, dass Passwörter nicht länger als 8 Zeichen sein können. vgl. http://www.macosxhints.com/article.php?story=20031107215426990

    Apple scheint es aber vergessen zu haben, den NIM vollständig auf die neue Methode anzupassen, denn wenn der root-User das PW so gespeichert hat, dann tickt der NIM aus.
    Also hat man 2 Möglichkeiten:
    1.) root ist aktiviert, hat aber ein sicheres Passwort oder
    2.) root ist deaktiviert

    Man deaktiviert die ShadowHash-Methode, indem man NIM startet und dann erst über Sicherheit --> Identifizieren alle Spielereien freischaltet.
    Dann klickt man in der Mitte auf users und dann auf root. Wenn man dann unten authentication_authority löscht und die Änderungen abspeichert, kann man den root-User deaktivieren.
    Ich bin mir nicht ganz sicher, aber ich denke, den root aktiviert zu lassen, ihm aber ein sicheres PW zu verpassen, ist der bessere Weg bis Apple den NIM-Bug endlich gefixt hat.
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
Die Seite wird geladen...
Ähnliche Themen - DISable root user Forum Datum
Frage zu Benutzer "root" Mac OS X 30.06.2016
Probleme mit "port": keine Root-Rechte mehr? Mac OS X 31.12.2015
Installation mit neuer SSD "Still waiting for root device" Mac OS X 09.11.2015
Thawte Root Zertifikat Yosemite Mac OS X 13.05.2015
Mac Pro 2009 bootet nicht: Waiting for root device Mac OS X 10.05.2015

Diese Seite empfehlen

Benutzerdefinierte Suche