Debian startet nach installation nicht

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von xmaikx, 26.07.2005.

  1. xmaikx

    xmaikx Thread Starter MacUser Mitglied

    Beiträge:
    19
    Zustimmungen:
    0
    MacUser seit:
    26.07.2005
    Linux startet nach installation nicht

    Hallo bin neu hier habe ein problem mit debian linux und bootx habe mir die netzwerkinstallations cd von debian runtergeladen und bootx.
    die installation über internet und bootx hat auch gut geklapt das einzige was er nicht gemacht hat war den bootloader quick oder wie das ding heißt zu installieren aber dafür habe ich ja bootx konnte auch so die installation beenden mit dem hinnweis von linux das ich linux manuell starten muß mit volgenden parametern

    /boot/vmlinux /dev/sda2 root=/dev/sda2

    habe bei bootx den kernel ja schon angegeben fehlt ja eigentlich nur noch die
    root und wenn ich da bei bootx sda2 angebe startet nur der kernel kurz und meldet mir den das ich eine andere root angeben soll

    habe aber linux auf sda2 installiert jedenfalls sagt mir linux wärend der partitionierung das die root so heißt

    Habe 2 scsi festplatten in einem umax pulsar eine an bus 0 (Mac os 9.2.2)
    eine an bus 1 (linux)
    Kann mir jemand helfen wie ich diese scheiße einstellen muß

    PS. falls ihr rechtschreibfehler finden solltet ignoriert sie einfach habe deshalb schon zweimal den text geändert habe es heute irgendwie nicht so mit rechtschreibung :D
     
    Zuletzt bearbeitet: 26.07.2005
  2. linuX|mic

    linuX|mic MacUser Mitglied

    Beiträge:
    65
    Zustimmungen:
    0
    MacUser seit:
    24.05.2005
    bootx kenne ich leider nicht aber:

    Das Problem was du beschreibst sollte dies sein:
    Du hast Linux auf der Zweiten Platte installiert, aber hast statt /dev/sdb2 /dev/sda2 angegeben. Daher kann er das root FS nicht finden.

    Es könnte aber auch sein, dass das Modul für deinen SCSI-Controller noch nicht geladen ist und er deshalb nicht auf die Festplatte zugreifen kann. Sprich, der Treiber ist nicht im Kernel eincompiliert und auch nicht in der initrd drin. Sagt der Kernel etwas wie: "Unable to mount root FS"?

    Wenn es die Sache mit der Platte ist und bootx einen Eingabeprompt hat könnte man sowas probieren wie:

    root=/dev/sdb2 auf der Zeile mit zu übergeben
     
    Zuletzt bearbeitet: 28.07.2005
Die Seite wird geladen...

Diese Seite empfehlen