Debian on iBook - X-Server Problem

Dieses Thema im Forum "MacBook" wurde erstellt von kermit, 28.05.2003.

  1. kermit

    kermit Thread Starter MacUser Mitglied

    Beiträge:
    997
    Zustimmungen:
    28
    MacUser seit:
    26.05.2003
    Hi,

    ich hoffe mal, hier sind auch ein paar Debianer...

    Folgendes Problem: Der X-Server will nicht ;-)

    Nun, was ich gemacht habe:
    Aktuellen benh Kernel gebacken. Mit 'lspci'
    wird die Radeon auch richtig ausgegeben.
    'xf86cfg -textmode' hängt, also
    'xf86cfg -textmode -nomodules' Da gibt es aber
    keine Radeon zur auswahl, nur eine Rage128
    und danach Radeon...egal beim starten des
    X-Servers wird mit no Screen found abgebrochen.
    Danach habe ich viele XF86config-4 aus dem Netz
    probiert (sollten doch, beinahe, dieselben sein für
    jedes iBook2.2?!) nun startet der X-Server. Allerdings
    ist alles "verzerrt" Außerdem ist auch so nichts zu
    erkennen (andere Farben bzw. Bildschirm ist einfach
    "bunt"). Nur die Darstellung des Mauszeigers ist i.O.

    Hat jemand eine Idee, was ich falsch mache?

    Gruß

    Thomas
     
  2. rupa108

    rupa108 MacUser Mitglied

    Beiträge:
    391
    Zustimmungen:
    1
    MacUser seit:
    03.02.2003
    Hallo,

    hab auf PPC nie Debian installiert, aber ich gehe davon aus, dass es analog zu x86 funktioniert.
    xf86cfg ist leider irgendwie kaputt.
    Du kannst mit :
    X -configure

    ein rudimentäres XF86config File erstellen, mit diesem sollte es möglich sein X zu starten.
    Natürlich nach /etc/X11/XF86config-4 kopieren.
    Wenn das funktiert, kannst du Auflösung, Farbtiefe ... einstellen. Jetzt sollte sich in X als root mit gesetzter DISPLAY Variable auch xf86cfg im grafischen Modus aufrufen lassen.

    Rupa
     
  3. kermit

    kermit Thread Starter MacUser Mitglied

    Beiträge:
    997
    Zustimmungen:
    28
    MacUser seit:
    26.05.2003
    xf86cfg geht alleine wohl nicht...
    Sieht ähnlich aus wie beim start vom
    X-Server. Allerdings wird nach "Ctrl+ALT+Backsp"
    angezeigt, das 8 Bit nicht unterstützt werden...

    Gruß

    Thomas
     
Die Seite wird geladen...

Diese Seite empfehlen