Darstellung von Flash in verschiedenen Browsern

Dieses Thema im Forum "Web Page Design" wurde erstellt von fox78, 22.02.2006.

  1. fox78

    fox78 Thread Starter MacUser Mitglied

    Beiträge:
    2.542
    Zustimmungen:
    212
    MacUser seit:
    02.02.2004
    Hallo,

    für meinen Vater bastel ich gerade eine HP mit RapidWeaver.
    Dabei habe ich auch eine Flash-Animation (auf die schnelle mit Keynote erstellt und exportiert). Gestern habe ich gemerkt, dass zumindest auf der Dose meiner Eltern die Seite mit der Animation nicht wunschgemäß dargestellt wird: Bei IE unter Win XP erscheinen rechts und links der Animation kleine Quadrate, bei Firefox sind an der gleichen Stelle Fragezeichen. Die Animation wird dennoch abgespielt. In Safari wird die Seite korrekt dargestellt.

    Eingefügt habe ich sie mit folgendem Code:

    Code:
    <object width="430"
               height="240">
    
    <param name="movie"
                value="rc-flash.swf" />
    
    <embed src=
              "http://michael.spaceshower.de/rc/rc-flash.swf"
                   width="430"
                   height="240"
                   border="3" />
    </object>
    Was kann ich dagegen tun oder woran liegts?

    Grüße fox78

    EDIT: Habe gerade im Quelltext der Seite gesehen, das da viermal "&#8232" auftaucht. Ist das die Ursache? Wie kommt das da hin?
     
  2. pichfl

    pichfl MacUser Mitglied

    Beiträge:
    134
    Zustimmungen:
    2
    MacUser seit:
    03.08.2005
    probier das einbinden der flash-file mal damit:
    http://blog.deconcept.com/flashobject/

    und ja, diese Zahlen sind "schuld", das sind unicode-codierte zeichen.
     
  3. fox78

    fox78 Thread Starter MacUser Mitglied

    Beiträge:
    2.542
    Zustimmungen:
    212
    MacUser seit:
    02.02.2004
    Danke für den Link.
    Ich frage mich nur, wie Unicode-Zeichen da hinein geraten?

    Grüße fox78
     
  4. pichfl

    pichfl MacUser Mitglied

    Beiträge:
    134
    Zustimmungen:
    2
    MacUser seit:
    03.08.2005
    Verwendest du ein CMS?
     
  5. fox78

    fox78 Thread Starter MacUser Mitglied

    Beiträge:
    2.542
    Zustimmungen:
    212
    MacUser seit:
    02.02.2004
    Nein, wie ich schrieb, erstelle ich die HP mit Rapidweaver.

    Grüße fox78
     
Die Seite wird geladen...

Diese Seite empfehlen