[B]Exel-Formel für die Notenberechnung[/B]

Diskutiere mit über: [B]Exel-Formel für die Notenberechnung[/B] im Office Software Forum

  1. gruebler262

    gruebler262 Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    Registriert seit:
    11.05.2005
    Liebe ForumUser,

    ich bin Exel-Laie möchte mit diesem Programm eine Notenübersicht erstellen. Dazu habe ich eine Liste angelegt, in der für eine Schulklasse die Punkteverteilung für diverse Aufgaben notiert wurde. Auch die Gesamtpunktzahl für jeden Schüler wird errechnet. Nun kommt mein Problem:

    Ich möchte, dass automatisch zu der jeweils erreichten Gesamtpunktzahl eine Note vergeben wird. Die Notenverteilung soll folgendermaßen sein:

    Note 1 66-58 Punkte
    Note 2 57-48
    Note 3 47-40
    Note 4 39-33
    Note 5 32-16
    Note 6 15-0

    Mithilfe welcher Formel kann aus einer beliebigen Gesamtpunktzahl der Spalte R eine Note in der Spalte S nach dem obigen Notenverteilungsschema berechnet werden?

    Vielen Dank im Voraus für eure Mühe.
     
  2. hagbard86

    hagbard86 MacUser Mitglied

    Beiträge:
    3.947
    Zustimmungen:
    42
    Registriert seit:
    30.03.2005
    also versteh ich das richtig du schreibst in r1 die punkte und in s soll die note erscheinen?

    hmm wenn das so ist müsste man irgend was mit >x machen
     
  3. leibniz_keks

    leibniz_keks MacUser Mitglied

    Beiträge:
    562
    Zustimmungen:
    4
    Registriert seit:
    31.07.2005
    Haben dazu was in der Schule gemacht, hier die Adresse unter der du die Excel-Datei runterladen kannst:

    http://www.freakalive.de/Noten.rar

    Hoffe das hilft dir,

    mfg

    //hab die Datei auch nochmal angehaengt ... Da *.xls leider nicht erlaubt ist hab ichs in *.txt umgeschrieben, musst einfach die Endung wieder zu *.xls umschreiben ...
     

    Anhänge:

  4. jakeBlues

    jakeBlues MacUser Mitglied

    Beiträge:
    95
    Zustimmungen:
    1
    Registriert seit:
    13.07.2004
    Eine Möglichkeit wäre, wenn Du folgende Formel benutzt:

    =SVERWEIS(Q5;Punktetabellen!A:X;Q$4)

    - in Q5 stehen dabei die Punkte, die der Schüler erreicht hat
    - in der Tabelle Punktetabellen!A:X stehen ab Zeile 2 verschiedene Punktetabellen. Wichtig dabei ist, dass in Spalte A die Punkte stehen - und zwar einzeln, keine Bereiche!, in B:X können verschiedene Punkteskalen stehen.
    - in Zeile 1 Punktetabellen!A:X kannst Du die Punktelisten mit einer Nummer versehen, die Du in der Formel dann in Zelle Q4 auswählst. So kannst Du z.B. für Klassenarbeiten andere Punktetabellen verwenden als z.B. für einen Vokabeltest.

    Sicher nicht die einfachste Lösung, aber ziemlich generisch!

    Grüße

    JakeBlues
     
  5. autoexec.bat

    autoexec.bat MacUser Mitglied

    Beiträge:
    2.130
    Zustimmungen:
    20
    Registriert seit:
    21.01.2005
    Ich würde da ne ganz normale Wenn-Dann-Sonst-Funktion nutzen:


    WENN($A1>=58;1;WENN($A2>=48;2;WENN($A3>=40;3;WENN($A4>=33;4;WENN($A5>=16;5;6)))))
     
  6. gruebler262

    gruebler262 Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    Registriert seit:
    11.05.2005
    Vielen Dank für die schnellen Antworten.

    zu hagbard86:
    Du hast richtig erkannt, was ich mit den Spalten R und S vor habe. Dein weiterer Tipp hilft mir nicht weiter, da ich die feinen Kniffe nicht kenne.

    zu leibniz_keks:
    Die Datei sieht klasse aus. Ich habe aber noch keine Idee wie ich deine Datei mit meiner verbinden kann. Hast du selbst eine Idee? Ich habe meine xls-Datei wie du als txt-Datei angefügt. Findest du eine Lösung?

    zu jakeBlues:
    Ich werde deine Formel mal in Ruhe ausprobieren. Das braucht aber etwas Zeit.

    zu -jalapeno-:
    Deine Formel sieht vielversprechend aus. Ich probiere sie ebenfalls aus.

    Nochmals vielen Danke euch allen.
     

    Anhänge:

  7. gruebler262

    gruebler262 Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    Registriert seit:
    11.05.2005
    zu -jalapeno-:
    Ich habe deine Formel meiner Tabelle angepasst und dann standen da auf einmal offensichtlich 27 korrekt berechnete Noten.

    =WENN($R2>=58;1;WENN($R2>=48;2;WENN($R2>=40;3;WENN($R2>=33;4;WENN($R2>=16;5;6)))))

    Vielen Dank dafür!!!
     
  8. gruebler262

    gruebler262 Thread Starter MacUser Mitglied

    Beiträge:
    32
    Zustimmungen:
    0
    Registriert seit:
    11.05.2005
    Und nun geht es weiter:

    Wie erstelle ich einen Notenspiegel (Übersicht über die Anzahl der Noten 1 bis 6)?
     
  9. Jabba

    Jabba MacUser Mitglied

    Beiträge:
    4.465
    Zustimmungen:
    109
    Registriert seit:
    21.11.2003
    :p

    Mein lieber Grübler, Du solltest mal Deinem Namen alle Ehre machen...
    Aber als Tip: Nimm die Formel zählenwenn...
    Beispiel: =zählenwenn(R1:R20;"1")
    HTH
     
  10. 93noddy

    93noddy MacUser Mitglied

    Beiträge:
    2.330
    Zustimmungen:
    0
    Registriert seit:
    31.05.2003
    hmmm...der Bereich 2 hat 9 Punkte, der Bereich 3 umfasst 7 Punkte, der Bereich 4 nur 6 Punkte?!
     
Die Seite wird geladen...
Ähnliche Themen - [B]Exel Formel Notenberechnung[ Forum Datum
Exel Benzinverbrauchtabelle Teilbetankung Office Software 21.03.2015
Eine exel datei auf mehreren Rechnern automatisch aktuell abspeichern Office Software 10.01.2015
Exel. Farbe in Feldern beim Kopien ändert sich. Was mach ich falsch? Office Software 08.11.2011
Formel Frage zu Exel (Stunden Addition über mehrere Tage) Office Software 04.04.2011
Exel: unterste (!) Zeile fixieren? Office Software 28.11.2010

Diese Seite empfehlen

Benutzerdefinierte Suche