Adminrechte weg - Gründe?

Dieses Thema im Forum "Mac OS X" wurde erstellt von Magenta, 11.07.2006.

  1. Magenta

    Magenta Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    11.07.2006
    Hallo Community.

    Ich bin im MAC-Support in der IT eines Fachverlages tätig und momentan mit einem Problem beschäftigt, was seit 3 Tagen an 2 PCs aufgetreten ist. Ich konnte mir nur mit einer Neuinstallation behelfen - denn ich kenne weder die Gründe, warum es so ist noch eine andere Lösung.

    Folgendes Szenario:
    Auf unseren MACs (G4 und G5 mit Mac OS X) existiert der normale "Root"-Account. Zusätzlich gibt es noch einen lokalen "Administrator" und das Userkonto, das per ADS erstellt wird.
    Das funktioniert eigentlich schon seit einiger Zeit ohne Probleme doch plötzlich gab es 2 G4s auf denen nicht mehr alles glatt lief.
    Das Userkonto, das von uns gleich am Anfang Adminrechte bekommt, hat plötzlich keine mehr. Der "Administrator" ebenfalls nicht.
    Also versuche ich, herauszubekommen, was passiert ist ->logge mich als Root ein und will die Rechte wieder verteilen. Aber:
    Auch der Root hat keine Adminrechte mehr.

    Ein cat /etc/groups im Terminal eingegeben ergibt
    [..]
    wheel:*:0:root
    [..]

    groups root listet als erstes ein wheel

    Wenn ich jetzt in die Userverwaltung gehe und einen Haken für Root oder Admin setzen will (beiden fehlt der Haken), damit der User den Computer Verwalten darf, wird dieser sofort wieder weggenommen.


    Hat jemand Hilfe?

    Lieben Gruß und vielen Dank
    Magenta
     
  2. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    Registriert seit:
    16.05.2002
    ...

    Hallo Magenta,

    was ist den ADS?

    Was ergibt?
    nidump passwd . | grep ^root ; nidump group . | grep wheel

    Gruß Andi
     
  3. Magenta

    Magenta Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    11.07.2006
    ADS = Active Directory Service .. Ist der Verzeichnisdienst von Microsoft Windows 2003 Server

    Und das hier ergab die Abfrage:
     

    Anhänge:

    • osx.jpg
      osx.jpg
      Dateigröße:
      9,3 KB
      Aufrufe:
      34
  4. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    Registriert seit:
    16.05.2002
    ...

    Hallo Magenta,

    stimmen denn UID und GID local und auf dem Server überein?

    Ich kann das nicht überprüfen - mangels Server :rolleyes: aber das könnte doch dein Problem sein...

    Gruß Andi
     
  5. Magenta

    Magenta Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    11.07.2006
    nein, der Vorschlag mit der UID und GID ist nicht die richtige Lösung.
    Wir haben das Problem auch beim lokalen Root und dem lokalen Administrator ..
     
  6. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    Registriert seit:
    16.05.2002
    ...

    Hallo Magenta,

    auch ohne Netzwerkkabel?

    Gruß Andi
     
Die Seite wird geladen...

Diese Seite empfehlen