absichern Webseiten über .htaccess

Dieses Thema im Forum "Sicherheit" wurde erstellt von Albatros59, 02.03.2003.

  1. Albatros59

    Albatros59 Thread Starter MacUser Mitglied

    Beiträge:
    4
    Zustimmungen:
    0
    MacUser seit:
    24.02.2003
    Hallo liebes Forum,

    hoffe ich bin hier richtig :( bzw. bin kurz davor zu verzweifeln!!

    Habe folgendes Problem.
    Arbeite mit einem iMac TFT 15'' mit MacOs 10.2.4. Habe auf dem Mac mehrere User & möchte über einen davon ins Web gehen.
    Das funktioniert soweit sehrgut.

    Nur möchte ich, dass nicht jeder gleich auf meine gesamte Hompage kommt. Also habe ich mir in den Ordner Web-Sites, den Ordner .htaccess und den dazugehörigen Ordner .htpasswd mit Terminal bzw. BBedit angelegt & beschrieben:

    htaccess:

    AuthType Basic
    AuthName "privater Bereich"
    AuthUserFile /Users/bruno/Sites/.htpasswd
    require user freund

    <Files ".htaccess">
    Order allow,deny
    Deny from all
    </Files>
    <Files ".htpasswd">
    Order allow,deny
    Deny from all
    </Files>

    htpasswd:

    freund:$1$s8cMgeRr$Q1BnFOe3I9uujCUMCHtSL

    Soweit,sogut.
    Nur beim Aufruf der Seite im Browser mit
    http://192.168.0.2/~bruno/ (bin hinter einem Netgear-Router)
    zeigt er mir alles genauso an, alsob ich keine htaccess Einstellung antiv wäre.

    Wer kann mir da ein paar Tipps geben ??

    Herzlichen dank im voraus an alle
    Bruno
     
  2. freeek!

    freeek! MacUser Mitglied

    Beiträge:
    614
    Zustimmungen:
    0
    MacUser seit:
    10.11.2002
    Server?!?

    Hi!

    Hmmm, bin mir nicht sicher, aber muss man für die .htaccess-Funktion nicht einen Webserver laufen lassen (www.apache.org) oder so ?!?!

    Wenn du local Websites aufrufst, wird diese ja nicht von einem Webserver zurück gegeben, kann somit auch deine .htaccess ignorieren.
    Funktioniert das ganze denn online ?!? - Wenn ja, liegt es def. an der Webserver-Geschichte!
     
  3. Musst Du dafür evtl noch Einstellungen in /etc/httpd/users/bruno.conf machen?
     
  4. Albatros59

    Albatros59 Thread Starter MacUser Mitglied

    Beiträge:
    4
    Zustimmungen:
    0
    MacUser seit:
    24.02.2003
    .htaccess

    Danke für Eure schnelle Antwort.

    Zur ersten Frage:
    Habe die Apache Webserverfunktion aktiviert (wollte PHP & SQLweg lassen).
    Ich sehe die Hompage auch im Büro. Also Apache, port forwarding (mit DYNDSN.org) passt.
    Nur, ich sehe leider zuviel ;) ...

    Zur zweiten Angabe:
    Habe den File bruno.conf gefunden unter /private/etc/httpd/users/bruno.conf
    steht folgendes drin:

    <Directory "/Users/bruno/Sites/">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    und was soll da falsch sein ??

    Liebe Grüße und danke clap für Eure Antworten
    Bruno
     
  5. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hi

    Das AllowOverride None

    Damit wird deine .htaccess-Datei nicht angewendet, da override = none, also keine weitere Konfiguration durch .htaccess erlaubt.

    HTH

    W
     
  6. Albatros59

    Albatros59 Thread Starter MacUser Mitglied

    Beiträge:
    4
    Zustimmungen:
    0
    MacUser seit:
    24.02.2003
    .htaccess

    danke für eure Hinweise. Es hat geklappt.
    Mußte nur mit BBedit die Zeile

    AllowOverride None mit
    AllowOverride AuthConfig ersetzen.

    Danke & Grüße an alle

    Bruno
     
Die Seite wird geladen...

Diese Seite empfehlen